cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Pavlos
Level: Powered On

Can't use AI Builder in Imported App

Hey Team, 

 

Hope you can help on this one. 

 

I recently imported an app to a new trial. I have a Object detection model in the trial which is working as I used it in another app just for testing. 

 

However, the app I have imported for some reason can't seem to find it. No mater what I do it shows there is no AI Model in the environment. I have checked the environments, I even tried to populate the Module ID in the properties but it still wont allow me to use my new model. 

 

Pavlos

4 REPLIES 4
PowerApps Staff JoeF-MSFT
PowerApps Staff

Re: Can't use AI Builder in Imported App

Hi @Pavlos,

 

As of today, it's not possible to import/export an AI Builder model across environment. 

 

What you should be able to do is import an app to an environment, and on that environment train a new AI Builder model and select that new model on the AI Builder model control on your imported app.

 

Pavlos
Level: Powered On

Re: Can't use AI Builder in Imported App

Hi @JoeF-MSFT ,

 

I am not referring to importing the AI Model. 

 

Here are the steps I followed and got the error:

1. I have imported an app from a different trial (which was integrated to an AI and was working fine)

2. I have created an Object detection model in the new trial 

3. Tried to use the new Object model within the recently imported app 

 

For some reason the app I have imported ws still pointing to the old AI model (the one from the previous trial). I verified that by the GUID (model ID property). I even tried to manually update the ID of the model to reflect the new Object Detection but it still didnt work. 

 

However, in order to avoid this bug you need to do the following before importing an app to new environment: 

1. Create a copy of your app

2. remove any connections to AI models 

3. Export the app and import to new trial

4. Connect the app to the Models created withig this trial/domain

 

Thanks,

Pavlos

 

Highlighted
PowerApps Staff JoeF-MSFT
PowerApps Staff

Re: Can't use AI Builder in Imported App

Hi @Pavlos,

 

Thanks for the reply. Just to double check, once imported you need to click on AI model on the properties panel to the right to select the Object Detection model on the imported environment. Did you do this?

 

 

2019-10-03_19-02-37.jpg 

 

Pavlos
Level: Powered On

Re: Can't use AI Builder in Imported App

Hi @JoeF-MSFT ,

 

Once I imported it I noticed there (exactly where you are pointing in the screenshot) that the model ID was pointing to the old AI Model. 

 

I went there and the PowerApps couldnt find the new AI model (which I published) in the new trial. So I decided to switch the Model ID instead but it didnt do the trick. 

 

So the only thing helped me is to go back to the old trial and remove the AI and re-import the app. Once I imported the new one and added the AI component it found the AI Model and allowed me to use it. 

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,360)