cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
kubalaml
Helper II
Helper II

Error: Process and save information from forms - "Encountered internal server error from the XRM API"

I've created, trained, and published my model in my sandbox environment. I setup a virtual agent to call this flow. While editing the flow, I can't save the action "Process and save information from forms". I get the following error:

 

Encountered internal server error from the XRM API. The tracking Id is '70d4c616-84ee-440f-9c6f-a4e9fab4e5c8'.

 

I can save other actions from AI Builder, just not this one. This was happening last night and I hoped it would fix itself, but this morning I am getting the exact same issue. 

 

I even tried going to my model, clicking on Use Model then clicking on New Flow. When I save this flow I get

 

"Multiple errors occurred: 'GatewayTimeout,GatewayTimeout'."

 

It looks like something is really broken in my environment and now I'm stuck.

1 ACCEPTED SOLUTION

Accepted Solutions
CedrickB
Power Apps
Power Apps

Hi,

 

Some hints to troubleshoot your problem

1. Is your flow inside a solution? That's required to make it work.

2. Are you able to quick test your model in the AI Builder model page? (Go to make.powerapps.com, click on AI Builder\Models in the left nav, click on your model and click on the "Quick test" button)

--> If so, can you create a basic flow calling "Process and save information from forms". If it works, try recreating your flow.

3. Are you able to call another Form Processing model in Flow?

--> If so try to recreate, train and publish your model

 

Hope it will help.

View solution in original post

2 REPLIES 2
CedrickB
Power Apps
Power Apps

Hi,

 

Some hints to troubleshoot your problem

1. Is your flow inside a solution? That's required to make it work.

2. Are you able to quick test your model in the AI Builder model page? (Go to make.powerapps.com, click on AI Builder\Models in the left nav, click on your model and click on the "Quick test" button)

--> If so, can you create a basic flow calling "Process and save information from forms". If it works, try recreating your flow.

3. Are you able to call another Form Processing model in Flow?

--> If so try to recreate, train and publish your model

 

Hope it will help.

View solution in original post

@CedrickB 

 


1. Is your flow inside a solution? That's required to make it work.


Ah that was it. I missed that part in the documentation. I put the flow in a solution, disabled it, edited it, and then it allowed me to save. 

 

I tried creating the flow directly from the model by clicking Use Model, and it failed there. It's weird that I have that option if it would never work since it doesn't create the flow in a solution. 

 

Anyways guess that doesn't matter now. It's working. Thanks for your help!

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Kudoed Authors
Users online (3,434)