cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
blaise
Frequent Visitor

'Null' predict result causes flow to fail

 
1 ACCEPTED SOLUTION

Accepted Solutions

Thanks a lot for taking the time to provide the info @blaise 

 

Indeed in this case, there is text, and you get back results: 

{"predictionOutput":{"results":[{"type":"Positive","score":0.8488399}]},"operationStatus":"Success","error":null}

 

For this case, do you get the same error on the Apply to each 2 step as seen on the screenshot you shared on your first message?

View solution in original post

11 REPLIES 11
JoeF-MSFT
Power Apps
Power Apps

Hi @blaise,

 

Could you please share a screenshot of the result you get on the Parse JSON step?

 

Thanks!

 

2019-07-15_21-02-35.png

blaise
Frequent Visitor

 

Thanks a lot @blaise !

 

It looks like the issue is on the predict action. Could you provide similar info like what you did for Parse JSON but for the precit action?

blaise
Frequent Visitor

 

Thanks @blaise !

 

It looks like the text that is being sent for text classification is empty.  "item/request""{\"text\":\"\"}"

 

Can you check that the Q_12A_Comments field has content in it?

blaise
Frequent Visitor

@JoeF-MSFT  Some of them are empty, but the majority have text in them. I expected the ones without text to fail, but they are all failing.

Hi @blaise, can you the output of predict and parse JSON for a case where Q_12A_Comments has text on it?

 

Thank you. 

blaise
Frequent Visitor

 

Thanks a lot for taking the time to provide the info @blaise 

 

Indeed in this case, there is text, and you get back results: 

{"predictionOutput":{"results":[{"type":"Positive","score":0.8488399}]},"operationStatus":"Success","error":null}

 

For this case, do you get the same error on the Apply to each 2 step as seen on the screenshot you shared on your first message?

View solution in original post

blaise
Frequent Visitor

@JoeF-MSFT It appears that it is working for those with text. I need to modify my flow as I need this to update records when it runs instead of creating new ones. I might have additional questions concerning that. When I tried to do update records earlier, everything else in my flow was the same but it did not update the records.

blaise
Frequent Visitor

 

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Top Kudoed Authors
Users online (55,229)