cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
semicolin
Frequent Visitor

Training failed and the model cannot be used.

Good morning,

 

I have been trying to train a complex model.  It consists of 49 collections (with 5+ PDF documents per collection), a total 257 images (pdfs), and 14 fields.  These are all US state vehicle registration documents, and the idea is to have one collection per state.  There are a few states that have different formats for the document, and some where the alignment isn't perfect as they are scanned, but this can happen so was hoping to train for it.

 

Upon tagging all of the fields in every document (some of which are not available in every document, and have been marked accordingly), I have tried to train the model and I always get an error: "Training failed and the model cannot be used."

 

There is no real explanation as to why it is failing, and I'd like to avoid deleting everything I've done and trying to build it one collection at a time to find the source.  So I am hoping someone may have some insight as to what I can try first.

 

I have gone through and made sure every PDF I have is readable, and even the preview of the data when selecting the fields in tagging shows correct data.  Also, I have reviewed the requirements on https://docs.microsoft.com/en-us/ai-builder/form-processing-model-requirements, and it seems to meet all requirments.  Total size of all documents combined is only 30 MBs.  The scans aren't perfect, but they are human readable.

 

Any help/ideas that can be provided would be great!

1 ACCEPTED SOLUTION

Accepted Solutions
antoinec
Power Apps
Power Apps

It seems the issue is triggered by automatic tagging of a field incorrectly double tagging. If you find the document which triggers the error, manually retagging all fields on that document should be a way to work around the issue until we fix it in product. Do let us know if this helps.

View solution in original post

8 REPLIES 8
antoinec
Power Apps
Power Apps

Hi,

Could you please reach out to aihelpen@microsoft.com with these details as well as the URL of the model you're getting this error for to help troubleshoot? You most definitely shouldn't be getting generic error messages if your data is properly setup.

Yes, I will, thank you!  I will respond with the resolution.

Thanks for sharing over email. It looks like one of your documents contains at least 2 tagged fields which include the same word. I'm not exactly sure how that is possible as the UI should prevent dual selection from happening, but it might be worth going through the docs to see if you notice anything fishy with the tagged contents. Do let us know if you find anything. (happy to continue over email as well if it's easier)

semicolin
Frequent Visitor

Thank you @antoinec,

 

Just to be clear with what I am looking for as I go through these documents.  Is this saying that I have the same word (position on the document) tagged twice with 2 different fields?  Such as where it would normally put a red box if I have the same word tagged with 2 different fields?  

semicolin
Frequent Visitor

OK, so I was pretty confident you and I were talking about the same thing.  I went through all of my documents and could not see this issue occurring anywhere, or anything else out of the ordinary either.

 

I succumbed to my next steps being to delete everything and starting again, and this time I am going to try to train the model for every 5 collections I add so I can try to narrow down the issue.

 

I'll let you know if I find the culprit and if I anything further is needed.

antoinec
Power Apps
Power Apps

Ah that's unfortunate and sounds fairly painful. We might be able to pinpoint the exact document which is causing issues by looking at telemetry in the future should this happen again. It was unfortunately a bit late yesterday here in France and I was lacking information to help pinpoint the problematic file (it was the 4th doc in the 41st collection) ... but we now have it in case the issue happens again. We'll also see if we can improve error messaging in product to make these types of unexpected issue troubleshooting easier in the future.

antoinec
Power Apps
Power Apps

It seems the issue is triggered by automatic tagging of a field incorrectly double tagging. If you find the document which triggers the error, manually retagging all fields on that document should be a way to work around the issue until we fix it in product. Do let us know if this helps.

View solution in original post

semicolin
Frequent Visitor

Thank you very much for your assistance @antoinec!

Helpful resources

Announcements
User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Kudoed Authors
Users online (1,706)