cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Victoria
Level: Powered On

Data connections to o365Users not working for just one user

I have a PA connecting to a SP list, where staff set their whereabouts daily.

One of my users can't connect to the data source. This user has exactly the same permissions as the rest of the team. She can access the list itself in SP and has rights to access the PA. But when she opens it via an embedded link on the SP page or via PAs mobile app, the app loads initially but spools on opening the second gallery screen saying 'getting your data'.

The PA has two data sources, the list and O365Users. I guess it's the O365Users that is causing the problem but why for just one user? 

 

Thanks, Vicki

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Data connections to o365Users not working for just one user

Hi @Victoria ,

Have you solved your problem?

 

If you have solved your problem, please go ahead to click "Accept as Solution" to identify this thread has been solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
4 REPLIES 4
Super User
Super User

Re: Data connections to o365Users not working for just one user

Have you checked to make sure that one user has a Profile and has instantiated their OneDrive?  I know a profile is required, but I think OneDrive may be also.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
Community Support Team
Community Support Team

Re: Data connections to o365Users not working for just one user

Hi @Victoria ,

Which PowerApps licenses does this user own?

Is the user existed within same Org as you?

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. Please make sure the user has enough permission to access your SP list data source, and could access your PowerApps app.

 

Also please check if the user has appropriate license to run a PowerApps app. If a user wants to run a PowerApps app, he must own Office 365 include PowerApps license at least.

Please check the following article for more details:

https://docs.microsoft.com/en-us/power-platform/admin/pricing-billing-skus#powerapps-for-office-365

 

Please also consider ask the user to clear cache of his browser, then access your app again, check if the issue is solved. Also please make sure the version of the PowerApps Mobile device in his device is the latest version, if not, ask him to upgrade it to the latest version.

 

If the issue still exists, please consider remove the permission to your SP Site and your canvas app for the user, then re-assign corresponding permissions to him, then try it again, check if the issue has been fixed.

Note: Please make sure the user is in same Org as you. In other words, you could not share an app with users outside your Org (external users).

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Victoria
Level: Powered On

Re: Data connections to o365Users not working for just one user

Thanks for your help. I found the issue. It appear user has multiple aliases email addresses. I had not used the master.
Kind regards.

Community Support Team
Community Support Team

Re: Data connections to o365Users not working for just one user

Hi @Victoria ,

Have you solved your problem?

 

If you have solved your problem, please go ahead to click "Accept as Solution" to identify this thread has been solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.