cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MRFowler
Level: Powered On

How to find out if there are any current operational or hosting issues

Beginning this morning (2019-01-29) an application began behaving differently when played by a user vs when the same app was opened in edit mode and played from there.  All changes are saved and published.   Why would there be behavior differences depending on whether the application is played from edit mode or via a direct link to play the application?  This is rather alarming.  All invocations (both edit-play & just play) are from web-based version of PowerApps and by the same user - i.e. not running in a different application execution or user privilege context.

 

Cannot find where to check and see if there are any current issues with the Microsoft site hosting my PowerApps 365 application.

 

Any help with be very much appreciated as this is a production system running a Medicaid reporting system for both the state and the federal government that has suddenly and mysteriously begun misbehaving.

 

Specific misbehaviors include:

     Showing the same (incorrect) record in a view detail screen regardless of which record is selected from the browse gallery screen that calls the view detail screen.

     After editing a record and successfully submitting it, the view detail screen the users ends up at after the successful submit does not show the correct values for the items that were just edited, but the correct values are stored in the data source.

 

9 REPLIES 9
Community Support Team
Community Support Team

Re: How to find out if there are any current operational or hosting issues

Hi @MRFowler,

 

I just tested with my app and I  cannot reproduce your issue. What is the data source of your app? Have you tried to create a new app and test? You could add the screenshots of the issue that you encountered. 

Do mask sensitive data before uploading.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
MRFowler
Level: Powered On

Re: How to find out if there are any current operational or hosting issues

The data sources are all sharepoint lists.

 

The basic problem is that I am seeing different behavior in the standard application when it is executed through the webplayer versus when it is played from the webeditor.

 

Specifically, it all works correctly and as designed when played from within the webeditor.

 

However, when executed through the webplayer, it exhibits the following anomalous behaviors:

 

  1. When you select an item from the browse records gallery screen and go to the view item detail screen and then edit that record, it successfully submits and indeed updates the sharepoint list properly, but when it returns to the view item detail screen that value displayed for the item that was changed in the edit action shows the original value (i.e. before the edit).
  2. When you return to the browse records gallery screen and select a different item to view the details, it shows you the original record you selected (and edited) NOT the new record you selected. 
  3. If you then select edit of this incorrectly displayed record however, you are taken to the edit item detail screen which properly displays the new record selected from the gallery (i.e. not the record displayed in the preceeding view item details screen).

It seems like the view item detail screen is not being properly refreshed, neither upon first entry from the browse records gallery screen nor upon return from the edit item detail screen ... but only from the webplayer.

 

I have recreated this behavior with a brand new test app & data as well.

 

Thoughts?

 

-mf

Moderator
Moderator

Re: How to find out if there are any current operational or hosting issues

@MRFowlercan you please PM me the following so we can take a look? I will notify the teams responsible for this area once I have this information.

 

1) Environment ID (not the name, the id is a sequence of letters and numbers)

2) App ID and ideally a SessionID (not the name, the id is a sequence of letters and numbers)

3) Ballpark Timestamps you experienced the issue.

 

If you don't know how to find 1 and 2, this explains how to find them -> https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/get-sessionid. That contains at least the AppID and we can find the environment id from there. 

MRFowler
Level: Powered On

Re: How to find out if there are any current operational or hosting issues

OK.  This has now become a SERIOUS issue. 

 

Have there been any recent changes to the PowerApps Web Player that would affect or currupt the view detail screen of the standard "build PowerApp from data" where data is a SharePoint list?

PowerApps Staff _Corey_
PowerApps Staff

Re: How to find out if there are any current operational or hosting issues

@MRFowler Is this all fields?  Or only some fields?  If only some fields, are they the same type of control? (i.e. ComboBox—there is a known issue with ComboBox is view forms that is expected to be rectified in release 3.19022 which is scheduled to be deployed next week).

MRFowler
Level: Powered On

Re: How to find out if there are any current operational or hosting issues

All ComboBoxes.

MRFowler
Level: Powered On

Re: How to find out if there are any current operational or hosting issues

Thanks.  I'll re-test after the deployment hits and let you know if that clears the problem up.

PowerApps Staff _Corey_
PowerApps Staff

Re: How to find out if there are any current operational or hosting issues

@MRFowler Release 3.19022 has now been deployed WW.  Can you please confirm if the issue you were experiencing still exists?  You will need to open, save, and republish any affected apps for the fix to take effect.  Thanks!

PowerApps Staff _Corey_
PowerApps Staff

Re: How to find out if there are any current operational or hosting issues

@MRFowler Any update on this?