cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
johnh3
Regular Visitor

400 error: The required field X data type is not supported

When using the trigger "Sharepoint: When a new item is created" I get the above error for a required lookup column. If I change it to not be required it will no longer give me the error however I want to make it required. Ive read some other messages on this forum that mention having too many lookup columns (more than 12) or having lookup columns that allow multiple values. Neither of these are my scenario.

1 ACCEPTED SOLUTION

Accepted Solutions

 

Hi @johnh3 ,

 

Please try to change the In this column to Name instead of Name(link to item).

Image reference:

95.PNG

 

Then you need to create a new flow to test it.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

5 REPLIES 5
sudharsan1985
Solution Sage
Solution Sage

Hi @johnh3 can you please post some screenshots for better clarity of the issue.

Hope it helps, please like it or mark it as a solution if it resolves your clarification or issue
-Sudharsan K...

@sudharsan1985 

Screen Shot 2020-05-31 at 9.22.35 AM.png

Toggling the "Require that this column contain information" switch will solve this problem.

Screen Shot 2020-05-31 at 9.24.19 AM.png

 

Hi @johnh3 ,

 

Thanks so much for posting in the Power Automate Community! It appears that you have found a solution to your issue!

If so, please click "Accept as Solution" on the reply that describes how you were able to solve your issue!

This makes your post much easier for other members of the community to see and find when looking for a solution!

Feel free to let us know if you have any other questions.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-bacao-msft The problem is that I want the field to be required... So its not a real solution, just a workaround currently... 

 

Hi @johnh3 ,

 

Please try to change the In this column to Name instead of Name(link to item).

Image reference:

95.PNG

 

Then you need to create a new flow to test it.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Users online (2,287)