cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ScottCostello
Frequent Visitor

A created table inside of a solution can't be accessed by flow

I create a Dataverse table 'Test Table' inside my environment solution.  I then wanted to create an automated workflow that is triggered by the Add/Update/Delete of items in this table.  However this table is not listed in the table list in the triggers dropdown.  

 

If I create a table outside of the solution I'm able to see it. 

 

Is 'Test Table' being filtered out because of user rights or am I doing something else wrong?  My account as Sys Admin rights.

 

edit: made reference to the fact I'm talking about a Dataverse Table

1 ACCEPTED SOLUTION

Accepted Solutions

@abm Thanks for the help!

 

I think the problem was I named the table the same thing as my solution name.  When I renamed the table from 'Scott Demo' to 'Demo' it magically showed up.  'Scott Demo' just so happen to be the name of my solution.  Perhaps that created an issue for some reason.

 

I'll call this problem solved! 🙂

View solution in original post

4 REPLIES 4
abm
Super User
Super User

Hi @ScottCostello 

 

Are you taking about an Excel table you created using PowerAutomate dynamically?  Could you please confirm which connector it is?

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

Oh Sorry @abm this is a Dataverse Table/Entity.

Hi @ScottCostello 

 

Thanks for your quick reply. It could be the refresh. Could you close your flow page. Back again and edit the flow. Check the Dataverse connector and see if it appears or not. Have you got lots of tables in your database?

 

Another option is try clicking the custom value and enter the table name manually.

 

image.png

 

 

Save the flow. Back to main menu then edit the flow again. Hopefully this should resolve the issue.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

@abm Thanks for the help!

 

I think the problem was I named the table the same thing as my solution name.  When I renamed the table from 'Scott Demo' to 'Demo' it magically showed up.  'Scott Demo' just so happen to be the name of my solution.  Perhaps that created an issue for some reason.

 

I'll call this problem solved! 🙂

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Difinity Conference 2022

Difinity Conference 2022

Register today for two amazing days of learning, featuring intensive learning sessions across multiple tracks, led by engaging and dynamic experts.

European SharePoint Conference

European SharePoint Conference

The European SharePoint Conference returns live and in-person November 28-December 1 with 4 Microsoft Keynotes, 9 Tutorials, and 120 Sessions.

Users online (1,989)