cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Accessing on premise SharePoint site with flow

I am struggling to connect a flow to my on-premise SharePoint site.

 

I am using SharePoint enterprise 2013.

 

I have installed the on-premise data gateway, this appears to be functioning with all ports open.

 

When I open flow, I connect to the data gateway and sign in successfully.

 

Then when I type in the url of my SharePoint site I receive the error:

We are unable to find the site address. Please try selecting a site address from the dropdown.

 

Is there a setup step I have missed?  Any one experienced something similar?

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Accessing on premise SharePoint site with flow

Hi @DanielMinett ,

 

How did you create a connection to SharePoint On-premises?

 

Please make sure you followed the steps suggested in the following blog:

https://powerapps.microsoft.com/en-us/blog/support-for-sharepoint-on-premises/

 

Further, if the Site address is not listed under the dropdown selections, please enter the correct site address manually by clicking the Enter custom value.

 

Please take a try with it.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Frequent Visitor

Re: Accessing on premise SharePoint site with flow

Thanks for the help, the blog entry was the same as I'd set up before but going through the process again I realised I was logging in with a cloud account, rather than the on premise domain account.  Switching logins seemed to work.

 

I still have to enter the web address as a custom value but I can now pull everything through.

View solution in original post

2 REPLIES 2
Highlighted
Community Support
Community Support

Re: Accessing on premise SharePoint site with flow

Hi @DanielMinett ,

 

How did you create a connection to SharePoint On-premises?

 

Please make sure you followed the steps suggested in the following blog:

https://powerapps.microsoft.com/en-us/blog/support-for-sharepoint-on-premises/

 

Further, if the Site address is not listed under the dropdown selections, please enter the correct site address manually by clicking the Enter custom value.

 

Please take a try with it.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Frequent Visitor

Re: Accessing on premise SharePoint site with flow

Thanks for the help, the blog entry was the same as I'd set up before but going through the process again I realised I was logging in with a cloud account, rather than the on premise domain account.  Switching logins seemed to work.

 

I still have to enter the web address as a custom value but I can now pull everything through.

View solution in original post

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (7,909)