cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
mmagura26
Level: Powered On

Action 'Start_an_approval' failed

Hello community,

 

I have been trying to test flows for my department that were created by another user in the same environment, it is a simple form response and email sent for approval. The flows were tested successfully last week by the person who created them, however they do not work when I try to test them. I also tried to create a test flow with the same functionality, answer a form, which creates a list on sharepoint, triggering the approval step.

 

I keep getting this error: 

"429. The request failed. Error code: 'XrmInstanceProvisioningIncomplete'. Error Message: 'A Common Data Service database for this environment has not completed provisioning or does not support the requested approvals functionality. A database administrator must save a Flow using approvals in order to complete provisioning.'."

 

Hopefully you'll be able to help thank you!

8 REPLIES 8
Dual Super User
Dual Super User

Re: Action 'Start_an_approval' failed

Hi @mmagura26 

 

There have been some similar issues faced by other users and here is a solved thread that might help you:

https://powerusers.microsoft.com/t5/General-Flow-Discussion/Action-Start-an-approval-failed/td-p/131...

Please try to incorporate the suggestions mentioned here and if you continue to face the errors, please post a screenshot here and we might be able to assist you better! 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

mmagura26
Level: Powered On

Re: Action 'Start_an_approval' failed

@yashag2255  thank you for answering.

As for the thread, it is a similar issue but my department uses the Flow for Office 365 Plan, and does not use the common data service, which is why we are confused because it was working perfectly two weeks ago.

Now it does not matter what kind of flow, even the most basic approval, runs fine until the "Start and wait for approval" step, and then runs for 20 minutes and fails and gives the same error message. 

My coworkers and I thought it might have something to do with recent updates or a problem with the approval connector, because all other connectors are working fine and the approval process worked perfectly 2 weeks ago.

Is this a possibility? Also is there any other potential reasons the connector is not working?

Thanks again, and hope to hear from you soon.

Dual Super User
Dual Super User

Re: Action 'Start_an_approval' failed

Hi @mmagura26 

 

So in the start an wait for an Approval action, does the email arrive? (the approval email to the approver field that you set in the action)

mmagura26
Level: Powered On

Re: Action 'Start_an_approval' failed

@yashag2255 thank you again for the response.

No, the emails are not sending for the approval. We thought it might have something to do with access, but when creating an entirely new test sharepoint, form, & flow it still gets the same error.

We've contacted the Office 365 admin at my department who will be in contact with Microsoft.

If you have any more troubleshooting tips, they would be greatly appreciated.

hubertlam
Level: Powered On

Re: Action 'Start_an_approval' failed

We in the NSW Department of Education are having the same problem! 😞 

J4TRK
Level: Powered On

Re: Action 'Start_an_approval' failed

I see this thread is well aged. Did you ever get resolution?

schuess3
Level: Powered On

Re: Action 'Start_an_approval' failed

I also have this issue. I am trying to use a simple approval flow with sharepoint. 

This is the error

error.png

This is the license:

license.png

 

We are NOT using CDS!

Dual Super User
Dual Super User

Re: Action 'Start_an_approval' failed

Hey @schuess3 

 

To use the approvals feature, it is mandatory to have the CDS provisioned. As the approvals are created as records and there are a couple of entities that the approvals depend on, it is necessary to have the CDS provisioned. 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 425 members 6,106 guests
Please welcome our newest community members: