cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
varshinims08
Helper III
Helper III

ActionFailed. No dependent action succeeded

Hi all,

 

I am getting ActionFailed. No dependent action succeeded error im my flow, however i am getting exact results..

 

Screenshot of my flow

69caff66-d03d-450f-b848-44a0730d84a3.png

d4a2012a-a15e-4e65-b19c-a5c099e5b8ef.png

 

And below is the condition

a80a2131-997d-4b22-846e-d38a99127cc1.png

 Someone please help me with this, I am not getting what is wrong here..

 

THANK YOU... 

6 REPLIES 6
Pstork1
Dual Super User III
Dual Super User III

Can you show a screenshot of the action causing the error?



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
Naveen_772
Advocate III
Advocate III

By looking at your flow my first guess will be that the List Actions may not be listing any records. I may be wrong. Can you provide some more information about the flow?

varshinims08
Helper III
Helper III

@Naveen_772 @Pstork1

 

Here is my flow

69caff66-d03d-450f-b848-44a0730d84a3.png

This is the list rows i am using to check if there is a already record exist with same JCN value as mention in filter query

27cd19c7-5349-435d-a670-640f67869821.png

This condition comes after List rows, And here I am getting error as "ActionFailed. No dependent action succeeded" 

a80a2131-997d-4b22-846e-d38a99127cc1.png

 

These are the steps after condition and they all are executing correctly even though it shows error.. 

d4a2012a-a15e-4e65-b19c-a5c099e5b8ef.png

And can you please tell me how to know whether List of rows is listing records or not. And what can i do if it not listing? 

 

Thank you... 

Pstork1
Dual Super User III
Dual Super User III

Nothing in your screenshots is showing as failed.  Please provide a shot of the action that is failing and throwing the error.  I'm assuming the condition is in an Apply to Each loop.  If it is please click through the loop results to the one that failed and show us a screenshot of the failure.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
varshinims08
Helper III
Helper III

 

Here is the error i am getting, 

 

c2915bc7-3547-436b-a0ed-71ca3beb25aa.png

And in no branch these are the actions i am using

a4e05f3a-055d-4934-819b-601328e58eef.png

As you can see all the actions are running successfully. And the only error i am getting is in condition present in Apply to each loop.

 

Thank you 

Pstork1
Dual Super User III
Dual Super User III

In the Apply to each loop click the link for Next failed.  That will take you to the iteration of the loop that failed so you can see which action failed and find the source of the error.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (57,308)