cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BabaBaba
Regular Visitor

ActionResponseSkipped

Hi 

I'm building a chat bot in Teams. Bot gets user's Email address from user and supply it to the Flow.

The Flow runs a Stored Procedure (SQL Server), supply the email address and gets Employee Number back (string). One record returns back by the Stored Procedure. This employee number is then returned back to the bot. The bot displays the number to the user.

 

I'm getting the following error on "Return value(s) to Power Virtual Agents"

ActionResponseSkipped. The execution of template action 'Return_value(s)_to_Power_Virtual_Agents' is skipped: the client application is not waiting for a response from service.

 

I'm getting this error while doing a Test in Flow. Also, I'm not getting any error in the bot, it is just empty value returned.

 

Stored Proc is returning the right data for the given email.

BabaBaba_0-1624457766094.png

 

The flow looks the following:

BabaBaba_1-1624457849223.png

 

The results from SP is passed along to Compose

BabaBaba_2-1624457895975.png

 

The expression (above) in Compose is:    outputs('SP_GUI')?['Table1']?[0]?['EmployeeGUI']

 

Finally, results of Compose output is returned as

BabaBaba_3-1624458100073.png

 

 

Any suggestions is appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions

You are not getting anything back because the code you are using in the compose is returning a null value.  Looking at the JSON you are using below it should be

body('SP_GUI')?['resultsets']?['Table1'][0]?['EmployeeGUI']


-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

7 REPLIES 7
Pstork1
Dual Super User
Dual Super User

You are using the Test link in the flow right?  If so then it bypasses the response because the Chatbot didn't actually call the flow.  To test the response make sure you test by invoking the chatbot.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Hi 

First thanks for a very prompt reply, appreciated.

I did mentioned in my question that no "value" is returned to the bot and no "error" returned to the bot. It's just empty.

While testing the flow, I see data returned by SP, however, an error (as mentioned) too.

Kind regards

As I mentioned, some of this is dependent on what you mean by "testing".  If you are running a test in Power Automate nothing will be returned.  That is what I thought you were doing and that is where we normally see this error.  If you are running a test in the bot then check the run in Power Automate and see what the output of your Compose looks like.  Make sure its a string and not an array.  

 

Could you also include a sample of the output returned from the Compose.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Hi Pstork1

I was able to get output from all but the compose (see the screenshot for compose below).

When I click on "Click to download" there is nothing coming up, just a blank webpage.

Please advise.

Kind regards

 

BabaBaba_0-1624545879350.png

 

 

 

BabaBaba_1-1624545906110.png

 

 

 

BabaBaba_2-1624545921168.png

 

 

Did you mean

 

BabaBaba_0-1624546289036.png

 

 

 

 

BabaBaba_1-1624546315040.png

 

You are not getting anything back because the code you are using in the compose is returning a null value.  Looking at the JSON you are using below it should be

body('SP_GUI')?['resultsets']?['Table1'][0]?['EmployeeGUI']


-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Thanks Pstork1,

It now works 🙂

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

PA Survey Carousel Image.png

We want to hear from you!

If you are a small business ISV/Reseller, share your thoughts with our research team.

Users online (1,213)