cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sprichar
Frequent Visitor

Add an email attachment to an existing Sharepoint list item

I am trying to make a flow that takes an email attachment and adds it to an existing Sharepoint list item. The body of the email should correlate with the item's field in the ItemID column. I've successfuly created a new item, but cannot figure out how to add it to an existing item instead.

 

Ultimately, I'm trying to add pen input images as attachments to list items, so any other workaround is also appreciated!

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @sprichar ,

I have made a test on my side, it does't has the issue you have mentioned.

Please make sure you have setted the value of 'Has Attachment' and 'Include Attachments' to Yes.

Capture10.PNG

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

5 REPLIES 5
Brad_Groux
Community Champion
Community Champion

You would Add a condition to a flow and then Use expressions in conditions to check multiple values that allows you to Apply to Each. For more information, you can view the A Visual Explanation of Flow Logical Expressions blog post and be sure to review How to Avoid Do-Until Loops and Improve Performance.

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

I've messed around with conditions, but not having any success yet. I received this error message:

 

InvalidTemplate. Unable to process template language expressions in action 'Add_attachment' inputs at line '1' and column '2580': 'The template language function 'base64ToBinary' expects its parameter to be a string. The provided value is of type 'Null'. Please see https://aka.ms/logicexpressions#base64ToBinary for usage details.'.

 

Here's the flow currently:

 

Screen Shot 2019-05-09 at 4.40.01 PM.png

Hi @sprichar ,

I have made a test on my side, it does't has the issue you have mentioned.

Please make sure you have setted the value of 'Has Attachment' and 'Include Attachments' to Yes.

Capture10.PNG

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hey,

can you please share the screen picture of the flow. with each step. I am getting the same error.

I couldn't get the whole flow in one image, but hopefully this helps.

Screen Shot 2019-05-24 at 3.20.32 PM.pngScreen Shot 2019-05-24 at 3.21.26 PM.pngScreen Shot 2019-05-24 at 3.24.41 PM.png

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (1,708)