cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jemmakeir
Frequent Visitor

Add row into excel failing when date field is blank

Hi

 

I am using a compose action to convert a date field from sharepoint in order to add it into an excel sheet. As this field is not and should not be compulsory it is often blank. for this reason the add row flow fails on any rows where this field is blank.

 

I need it to add the row either leaving that cell blank or inputting something like 'NA'Capture.JPG

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @jemmakeir 

 

Try this:

if(empty(outputs('ActiveDueDate')),null,outputs('ActiveDueDate'))
 

Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





View solution in original post

6 REPLIES 6
Jcook
Super User III
Super User III

Hello @jemmakeir 

Yiu can try using an if() expression in that date field. Something like:

if(empty(‘Your Date’), ‘null’, ‘Your Date’)

 

note that ‘Your Date’ is your dynamic content for the date. And the ‘null’ this the expression null


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





jemmakeir
Frequent Visitor

Thanks, I tried this but it states expression is invalid: if(empty(‘outputs('ActiveDueDate')’), ‘null’, ‘outputs('ActiveDueDate')’)

Hi @jemmakeir 

 

Try this:

if(empty(outputs('ActiveDueDate')),null,outputs('ActiveDueDate'))
 

Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





View solution in original post

jemmakeir
Frequent Visitor

perfect, thank you 🙂 

shu
Microsoft
Microsoft

@jemmakeir  I have tested from my side that even the 'Due Date' is blank, the 'Add a row into a table' should still run with success.

Could you please provide a screenshot of the error you are having?

 

Best Regards,

 

Jessie Chen

 

Support Engineer

Asia Dynamics 365 Support

Customer Services and Support

jemmakeir
Frequent Visitor

Hi, thanks, the prior suggestion solved this issue 🙂

Helpful resources

Announcements
MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (96,867)