cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
rsymmons
Resolver I
Resolver I

Apply to all generates multiple emails

I'm relatively new to Flow and by no means an expert. I've created a Flow to save attachments sent by email into a SharePoint library which then uses a condtion to only save PDF files as per the below:

 

@contains(items('Apply_to_each_Attachment_on_the_email')?['Name'], '.pdf')

 

I've set the "if no" variable to "reply to email" which is working, however is sending multiple emails according to the number of attachments in the email that do not meet the .pdf requirements. How can I ammend the Flow so that only one email is sent?

 

I assume this is because of the "apply_to_each_attahment_on_the_email) section of the condition but I have no idea how to go about fixing this. Any help greatly appreciated. 

 

Thanks,

Rob

1 ACCEPTED SOLUTION

Accepted Solutions

Think I've got to the bottom of my issue which was simply creating an Exchange rule to exclude signatures being applied to the recipient connector. This reduced the bulk of automated responses and the reply to email function is only sending replies to "user attached files". 

 

 

View solution in original post

5 REPLIES 5
v-yuazh-msft
Community Support
Community Support

Hi @rsymmons,

 

I have made a test on my side, please refer to screenshot below to create the flow:

Capture.PNG

Capture.PNG

 

 

Best regards,

Alice

GabrielStJohn
Community Champion
Community Champion

Hello, @rsymmons!

Thank you for posting on the Flow Community Forum! Have you had an opportunity to apply @v-yuazh-msft‘s recommendation to adapt your Flow? If yes, and you find that solution to be satisfactory, please go ahead and click “Accept as Solution” so that this thread will be marked for other users to easily identify!

Thank you for being an active member of the Flow Community!

-Gabriel
Flow Community Manager

- Gabriel
Community Manager
Power Automate | Power Virtual Agents
Super User Program Manager



Hi Alice, 

 

Thanks for the suggestion I'll test and confirm if working. 

 

Rob

Alice,

 

I've had a chance to test your suggestion and it only seems to send the message when a PDF is submitted rather than not submitted. Any idea what could be going wrong? I'm pretty sure I've got this setup as suggested.

Think I've got to the bottom of my issue which was simply creating an Exchange rule to exclude signatures being applied to the recipient connector. This reduced the bulk of automated responses and the reply to email function is only sending replies to "user attached files". 

 

 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (2,419)