cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Dave_H
Frequent Visitor

Approval Flow only working when document is dragged and dropped

I am using the Flow template 'Approve a document using SharePoint Content Approval'.  I have noticed that the flow succeeds when a new document is dragged and dropped into the document library, however, if I add a new document by choosing the option to upload a document to the document library, the flow fails with the following message:  "The ETag of this item does not match the one used for setting content approval status. The contents of the item may have changed before the action was completed."  Any ideas on why this is happening and how to resolve?  Thanks.

5 REPLIES 5
Super User
Super User

Re: Approval Flow only working when document is dragged and dropped

Can you upload a screenshot of the run history of the failing flow.

Dave_H
Frequent Visitor

Re: Approval Flow only working when document is dragged and dropped

Flow Failure Screenshot 1.PNGFlow Failure Screenshot 2.PNGFlow Failure Screenshot 3.PNG

Community Support
Community Support

Re: Approval Flow only working when document is dragged and dropped

Hi @Dave_H

 

Could you please share a full screenshot of the configuration of your flow?

I have made a test on my side and when configuring the Id of Set content approval status, the Dynamic content ID from the trigger is used.

Did you use ItemId from the action Get file metadata? That does happen to the mistakes you said.

Please reconfigure Set content approval status action, using the ID from trigger.

Take a try and let me know if issue still exist.

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Dave_H
Frequent Visitor

Re: Approval Flow only working when document is dragged and dropped

Flow.png

Thanks, Barry.  I used Identifier from the action Get file metadata and ID for the Set content approval status action.

Highlighted
Dave_H
Frequent Visitor

Re: Approval Flow only working when document is dragged and dropped

Any more ideas on why this is happening and how to resolve?  I have been trying unsuccessfully to find an answer to why the template works when documents are dragged and dropped into the document library, but fails when a document is added through the "upload" option.  Thanks.

Helpful resources

Announcements
MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.

firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Automate Community!

firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Users online (7,274)