cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted

Approval Flow sends email for every response

I am trying to build an approval email Flow which sends an email for every response.

I have built the following steps - manually trigger a flow - start and wait for an approval - apply to each response - send an email 

 

I receive actionfailed at apply to each action with the following errors; 

ActionFailed. An action failed. No dependent actions succeeded.
 
Send an email error; 
InvalidTemplate. Unable to process template language expressions in action 'Send_an_email' inputs at line '1' and column '2565': 'The template language expression 'json(decodeBase64(triggerOutputs().headers['X-MS-APIM-Tokens']))['$connections']['shared_office365']['connectionId']' cannot be evaluated because property 'shared_office365' doesn't exist, available properties are 'shared_approvals'. Please see https://aka.ms/logicexpressions for usage details.'.
1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Approval Flow sends email for every response

Hi @Basic_User007 ,

 

I guess you might have added Send_an_email action to the previously configured Flow to get this error.

Following method is generally used to solve similar errors.

Please try to export Flow as a .zip file, then re-import it as a new Flow and configure the relevant conenction so that the problem can be solved.

Hope it helps.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
Community Support Team
Community Support Team

Re: Approval Flow sends email for every response

Hi @Basic_User007 ,

 

I guess you might have added Send_an_email action to the previously configured Flow to get this error.

Following method is generally used to solve similar errors.

Please try to export Flow as a .zip file, then re-import it as a new Flow and configure the relevant conenction so that the problem can be solved.

Hope it helps.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 394 members 5,756 guests
Please welcome our newest community members: