cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
rich106
Level: Powered On

Approval - String as assignedTo fails

I am appending an array of values (usually only one value anyways) to a string, and then attempting to use that string as the assignedTo value for the approval connector. This fails, saying inputs are invalid. Does the approval connection not accept string inputs? If not, any other way to do this?

2 REPLIES 2
MartinBurman
Level: Powered On

Re: Approval - String as assignedTo fails

Im running into the same problem, assignedto doesnt accept my email string.

Community Support Team
Community Support Team

Re: Approval - String as assignedTo fails

Hi @rich106,

 

Could you please share a screenshot of your flow's configuration?

Do you want to retrieve a value from an array and append it to a String as the Assigned to value?

 

I have made a test on my side and please take a try with the following workaround:

  • Add a "When an item is created" trigger, specify Site Address and List Name.
  • Add a "Select" action, From set to Approvers dynamic content of the trigger. Within Map entry, type one entry, The key set to Email and the corresponding value set to Approvers Email dynamic content.

Note: The Approvers column is a Person or Group type column with multiple selections in my SharePoint list. The result the "Select" action returned is an array of email addresses

 

  • Add a Variables-> "Initialize variable" action, Name set to FinalString, Type set to String and Value set to empty.
  • Add a "Apply to each" action, input parameter set to output of "Select" action.
  • Within "Apply to each" action, add a Compose action, Inputs set to following formula:
concat(item()?['Email'],';',variables('FinalString'))
  • Add a "Set variable" action, Name choose FinalString and Value set to output of the "Compose" action (Click "See more" button to see the Dynamic content).
  • Under the "Apply to each" action, add a "Start an approval" action, Assigned to field set to FinalString variable.

Image reference:1.JPG

 

2.JPG

The flow works successfully as below:5.JPG

 

3.JPG

 

Please check if the string that you provided within Assigned to field includes proper email addresses. 

 

Best regards,

Kris

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
firstImage

Power Platform Online Conference

Join us for the first ever Power Platform Online Conference!

firstImage

Coming Soon: T-shirt Design Contest

Keep your eyes open for our upcoming T-shirt design contest!

firstImage

Incoming: New and improved badges!

Look out for new contribution recognition badges coming SOON!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Top Solution Authors
Top Kudoed Authors
Users online (6,670)