cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
delucaezequiel
Regular Visitor

Approval Workflow is not automatically triggered

Hi:

I am trying to create an approval workflow for our SharePoint List. The flow is as follows:

1) Triggered: When an item is created or modified (SharePoint Site and List set from the drop down menu)

2) Start an approval (Assigned to is a distribution list)

3) Condition (Reply equals to Approved)

1.jpg

It seems that the flow is never triggered. I read on a post that it can take up to 90 minutes to start, however I already wait 3 hours and the mail was not send. Do you know if there is an issue with SharePoint and Flow or if there is anything that I should set in another way?

Here is where it get stuck

1.jpg

1 ACCEPTED SOLUTION

Accepted Solutions
delucaezequiel
Regular Visitor

It looks like there is an issue with Start an approval Task. It is not sending the e-mail to the distribution list. As a workarround I created the following flow:

1) Trigger: When an item is created or updated

2) Conditon: Content approval status is Pending Note: This is to avoid a loop when I update the item at the end of the flow

3) Action: Send an email with options (Options: Approve or Reject)

4) Conditon: If SelectedOption is Approve

5) Action: Inform item creator of Approval/Rejection

6) Action: Set content approval status to Approved/Rejected

1.jpg

 

4.jpg

View solution in original post

4 REPLIES 4
ChristianAbata
Community Champion
Community Champion

hi @delucaezequiel  please could you share an screanshot? because if is not triggering could be a trigger problem, and probably you need to open an MS support case.



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

Hello @delucaezequiel why do you say the flow is not triggered? based on the screenshot, the trigger ran but the approval action is waiting the response.  

Hi the first trigger tooks to long to run (almost 4 hours). When a new item was added later it took about 20 minutes. However in both flows the e-mail was not send to the distribution list. I am one of the members of that distribution list and did not receive the notification. Also I contact the remaining 4 members and none of them receive the e-mail requesting the approval. There may be an issue with that step that I need to fix as if nobody receive the approval notification the flow will never go to the next step

delucaezequiel
Regular Visitor

It looks like there is an issue with Start an approval Task. It is not sending the e-mail to the distribution list. As a workarround I created the following flow:

1) Trigger: When an item is created or updated

2) Conditon: Content approval status is Pending Note: This is to avoid a loop when I update the item at the end of the flow

3) Action: Send an email with options (Options: Approve or Reject)

4) Conditon: If SelectedOption is Approve

5) Action: Inform item creator of Approval/Rejection

6) Action: Set content approval status to Approved/Rejected

1.jpg

 

4.jpg

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (3,434)