cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Charles-v-D
Level: Powered On

Attachment to New Approval Action

Hi All,

 

I noticed that we have new Approval Action in MS Flow which allows for adding attachments to an approval request. GREAT!!!

BUT: it does not work for me... let me elaborate....

 

In my Flow I used to have a parallel branch to send A) the approval request without attachment:

ap1.JPGold type approval without capability to add attachment

 

 

 

 

 

 

 

 

 

 

 

 

and B) parallel mail with attachment:

ap2.JPGmail with attachment

 

 

 

 

 

 

 

 

 

 

 

 

 

The Attachment file is an array variable which stores 1 or more attachments:

ap4.JPGattachment creation

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The above described elements work fine! My flow has been used 1000+ times by 12+ users.

How happy I was that I could now eliminate the parallel e-mail and include attachments into a approval request. I followed the standard procedure for this inside the NEW action. Like this:

ap3.JPGapproval request WITH attachment

 

 

 

 

 

 

 

 

 

 

 

 

 

The Flow goes into error when I do it like this. The error message reads:

ap5.JPGerror when approval has attachment array

 

 

 

 

Does anyone knows what I'm doing wrong?

Thank you for your help!

 

Regards

Charles

@approval with attachment

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support Team
Community Support Team

Re: Attachment to New Approval Action

Hi @Charles-v-D,

 

The property name in the Attachment object should be "content" instead of "ContentBytes", please have a try with it.

Annotation 2019-12-10 091952.png

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
Highlighted
Community Support Team
Community Support Team

Re: Attachment to New Approval Action

Hi @Charles-v-D,

 

The property name in the Attachment object should be "content" instead of "ContentBytes", please have a try with it.

Annotation 2019-12-10 091952.png

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Charles-v-D
Level: Powered On

Re: Attachment to New Approval Action

@v-litu-msft 

thanks, this resolved the issue!

 

Regards

charles

 

 

Helpful resources

Announcements
firstImage

New Ranks and Rank Icons in April

Read the announcement for more information!

firstImage

Better Together Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (3,983)