cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Zam
New Member

Automate to send last modified file in sharepoint folder as an attachment

Hello 

 

I've got some files on a sharepoint folder that is updated almost daily. The last modified file is sent out to the team on Thursday mornings. 

 

I would like to automate this using Power Automate. 

 

I use the "schedule an action" workflow and then use the "get specified file (properties only)" action. But I can't seem to figure out how to instruct the workflow to pick the last modified file in the sharepoint folder.

 

This thread  has got something similar to what I am looking for. But I cannot get it to work. 

 

A few  issues here. 

1. My files are in the following location Site address -->"Documents" folder --> "General folder" - I cannot seem to select the general folder. I am able to select my site address. But for Library name, the only options available is "Documents" or "Custom".  And the options available within Custom are options that I do not recognise. 

2. Is "get specified file (properties only)" the right option if I want the file to be sent as an attachment. I don't understand what "properties only" mean. 

3. I tried to use the points from the thread above to select the last modified file, but when I test the flow, it gives me an error saying that "modified column does not exist". Picture attached below

 

Any guidance on this would be much appreciated.

SnipImage1.jpg

 

 

Thanks

Best regards

Zam 

2 REPLIES 2
ChristianAbata
Super User II
Super User II

hi @Zam  maeby is because you have modified and is Modified with capital letter. Please try. 😉



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

Hi @ChristianAbata 

 

Thanks for pointing this out. It seemed to get through okay after capitalising the "M". But it failed further downflow.

 

I have attached the screenshots of my flow and the error messages.

 

Image 1 - flow structure 

Image 2 - error message (the error was on the 3rd component of the flow, i.e "Apply to each 2")

Image 3 - location of file that I want as attachment. It is in Documents --> General

 

Would be great if you could look at the screenshots and help me understand what I am doing wrong.

 

Image 2Image 2Image 3Image 3Image 1Image 1 

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Kudoed Authors
Users online (1,965)