cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Azure Automation: Get job output not returning Content

I've created a Flow that creates an Azure Automation job via HTTP. I then take the JobID returned by this and attempt to get the output from this job. For some reason, the output to only provides a "Status code" and "Headers" but no Content. If I copy a paste a static JobID into "Get job output" however, I do receive the Content of the output.

 

Thoughts?

2 REPLIES 2
Highlighted
Community Support
Community Support

Re: Azure Automation: Get job output not returning Content

Hi @pdschweiger,

 

Could you please share a screenshot of the configuration of your flow?

Does the Get job output wouldn't return Content when take the JobID returned from Http and would return Content when paste a static JobID into "Get job output"?

 

Does the JobID returned from Http the same as the static JobID that you mentioned?

 

Please share more details so we would try to provide a proper workaround for you.

 

Best regards,

Alice

Highlighted
Frequent Visitor

Re: Azure Automation: Get job output not returning Content

 

Here is the configuration.Config1.PNG

Config2.PNG

This first result is the real issue where only Headers are returned.

 

Results1.PNG

 

 

Now if I take a Job ID from a separate run and insert it into "Get job output", I get the correct Content.

Results2.PNG

 

 

 

 

 

 

 

 

 

 

 

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Kudoed Authors
Users online (7,082)