cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Mustaque_Ehiya
Level: Powered On

Azure Devops _ when a work item is updated trigger is not getting execxuted.

Hi,

 

I am trying to build a flow in ADO when a work item is updated (primarily when the state is changed from New to Active), but it is failing without execution and throwing different errrors.  Please let me know how to fix this error.

Note - this trigger is showing as a 'Preview'.

 

notinitiated.PNGbad gateway.PNG520-Api token failure.PNG520.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Dual Super User
Dual Super User

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

Hi @Mustaque_Ehiya This could be a caching issue with the connector. Can you please delete the current connection to azure devops and create a new connection after refreshing the page? Alternatively, how are you testing this? I am hoping you are using a fresh test and not testing based on any previous test runs data.  

 

View solution in original post

23 REPLIES 23
Dual Super User
Dual Super User

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

HI @Mustaque_Ehiya 

 

Can you please share a screenshot of the flow trigger?

Mustaque_Ehiya
Level: Powered On

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

wi-updated.PNG

@yashag2255- Building a simple one to test the trigger but this is not working.

Dual Super User
Dual Super User

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

Hi @Mustaque_Ehiya 

 

Can you share some more details? Which fields are you updting in Azure Devops and what fields do you want to track in the flow?

 

I tried recreating the flow and it works just fine in my case. 

 

Can you also try logging out of the browser and close the current session and start a fresh session and check if you still are facing the issue?

 

Mustaque_Ehiya
Level: Powered On

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

wi-updated.PNG

 

Hi @yashag2255  this is my flow and I tried a new session but still it is not getting executed.  I tried from Edge and Chrome browsers but results are same.

Dual Super User
Dual Super User

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

Hi @Mustaque_Ehiya This is wierd. I am doing the exact same thing and it is working just fine in my environment. (Along with the condition in the Agile project type). Can you confirm to me that the project name and the team names etc. are being selected from the drop downs in flow and you are not manually typing in those?

Mustaque_Ehiya
Level: Powered On

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

@yashag2255- Yes, nothing was typed manually and they were selected only from the drop down. 

Mustaque_Ehiya
Level: Powered On

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

Additional info - I created this flow using 'Automated from Blank' option.

Dual Super User
Dual Super User

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

Hi @Mustaque_Ehiya 

 

Can you run the flow again and change some value on the user story in Az DevOps and post a screenshot of the error that you are getting?

 

 

Dual Super User
Dual Super User

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

@Mustaque_Ehiya This shouldn't be a problem as long as you are using the right credentials for the connection to azure devops. 


@Mustaque_Ehiya wrote:

Additional info - I created this flow using 'Automated from Blank' option.


 

Mustaque_Ehiya
Level: Powered On

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

Timeout.PNG

 

I got this 429 error - RATE LIMIT IS EXCEEDED.  .. once.

 

I logged out from Flow, closed the browser and opened a new session and ran the flow again but still same results - this flow is not getting executed and it runs for a long time and throwing different errors each time.

 

This is the message I got  from the last flow.

 

 

Dual Super User
Dual Super User

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

Hi @Mustaque_Ehiya 

 

I have been trying that at my end too and the flow takes more time than usual to trigger and get the response once the item is modified. 

 

Based on the error, it seems that the flow test is not recognising any action performed in Azure Devops. Can you start a new flow and -> manually triggered-> action is list items from azure devops and select the same project as in this flow and put the task id as one of the tasks that you are trying to change and get the information. I just want to check it is the right project and the task is coming in from other actions. 

 

Hope this Helps!

Mustaque_Ehiya
Level: Powered On

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

No difference in any error logs today.  I got the same time out errors and 429 errors.  Additionally had a new error.

 

1306-4.PNG1306-2.PNG1306-1.PNG

 

CLIENT REQUEST ABORTED error was the new one shown today.  In the TRIGGER, I have added all the values that I can fill in.  Area and Iteration Path were manually copied as Text.

 

1306-5.PNG

 

Please find below my ADO details fyi.  Pls let me know if I I need to fill in any value differently.

 

1306-6.PNG

 

Note - Below is the run time log for today.  As you see, they run for a very long time 15-20 mts and is getting stuck in the trigger itself and not going to the next step.

 

1306-7.PNG

Dual Super User
Dual Super User

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

Hi @Mustaque_Ehiya 

 

Can you please create a new test item and see what all states are available? I am guessing we are looking into a different project type that has different state values!

Mustaque_Ehiya
Level: Powered On

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

@yashag2255-  in the trigger I am not setting any state.   As you see, I am filling in only the details shown in the TRIGGER and it is not getting executed.  Do I need to fill in anything differently in the below fields?

1306-5.PNG

Dual Super User
Dual Super User

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

Hey @Mustaque_Ehiya  Got it. Please remove the trigger flow manually (the triiger button) from the flow. You are using two triggers in flow here (The manual button and the When a work item is updated) and you cannot use 2 trigers in one flow. Please remove the first one. The "When a work item is updated" is sufficient enough for this flow.

 

Hope this Helps!

Mustaque_Ehiya
Level: Powered On

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

No luck this time as well.

 

I created a new flow with only the WORK ITEM UPDATED trigger .. with mandatory values only and all the fields populated... --> Same results --> Got 429 error.

 

1306-9.PNG1306-8.PNG

 

To check if there is any issue with the ADO Organization that I am working with (though it works fine for me with creating and updating items in that)... I created a copy and changed it to a different organization (OUR LIVE) and tried, same 429 error.

 

1306-10.PNG

 

note - one thing i observed is --> When i clicked the TEST button for the flow and moved to the Kanban board and came back (even without updating any story), the flow got triggered...  Many resources are active in this Team.  They might be doing some update .. But I am not exactly sure and cannot confirm on this.

 

Can you pls check how it works on your items (whether the flow is triggered even without any updates) ?

Highlighted
Dual Super User
Dual Super User

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

Hi @Mustaque_Ehiya 

 

Yes. I did test with my work items and it does not trigger unless and until a work item is changed. What Flow plan are you using? In the first error it says that too many tries and try again in 9 seconds and this is a very wierd error. Did you try changing the concurrency control settings in the flow trigger (by pressing the ... on the action and clickin on settings)?

Mustaque_Ehiya
Level: Powered On

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

I do not change any settings w.r.t. flow other than adding values for the trigger and testing it.    

I will confirm on the trigger behavior again with isolated ORG where I am the only user. 

Mustaque_Ehiya
Level: Powered On

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

Hi - When I test the flow and move across tabs and came back to the FLOW screen, the flow got executed and failed with 429 error.

 

Note - I confirmed that I am the only user in my test org and I did no update to any user story. but the flow got triggered when I revisited the FLOW screen after moving across the opened tabs in the browser.

 

1403-1.PNG

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (4,679)