cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Dual Super User III
Dual Super User III

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

Hi @Mustaque_Ehiya This could be a caching issue with the connector. Can you please delete the current connection to azure devops and create a new connection after refreshing the page? Alternatively, how are you testing this? I am hoping you are using a fresh test and not testing based on any previous test runs data.  

 

View solution in original post

Highlighted
Helper III
Helper III

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

Huzzah - atlast the flow ran succesfully after I deleted the existing connected and created a new one !

Thanks.  I shall check the conditions and will report how that goes.

 

1403-2.PNG

Highlighted
New Member

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

Hello,

 

I am having a very similar issue trying to update an existing Azure DevOps work item. I am using MS Flow to parse through a list of Work Items and if there is a title match then update the work item with the body text of an email. If no match is found, then create a new work item. The flow works for creating new work items. If the match is found and the flow tries to update the work item it throws an error "A potentially dangerous Request.Path value was detected from the client..."

 

I followed this thread and deleted the existing connection to Azure DevOps, cleared the cache in the browser, and re-created a connection to Azure DevOps. I also tried creating two connections Azure DevOps, one for create and one for update of the Work Items but that still does not work. I test with new test data each time.

 

Image 34.pngImage 35.png

Highlighted
Dual Super User III
Dual Super User III

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

Hey @NKK 

 

From the error, I can see that you are wrongly referring the item ID in the update action. Can you share a screenshot of the update work item in edit mode so that I can better identify the issue and assist you with this. 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Highlighted
New Member

Re: Azure Devops _ when a work item is updated trigger is not getting execxuted.

Updated the ID and that worked. Thanks!

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Upcoming Events

Experience what’s next for Power Automate

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Top Solution Authors
Top Kudoed Authors
Users online (6,831)