cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New-Bie
Level: Powered On

Bad request - Get User Profile

Hi,

 

I'm trying to create a simple flow that has 3 steps -

1. When a new item is created (SharePoint List)

2. Get User Profile

3. Create a task (Planner)

 

The flow is running with errors - Get User Profile is failing with 'NotFound' message. Below is the Body of the Output -

 

{ "status": 404,
"message": "No user found with the specified id.",
"source": "office365usersconnectionprovider-westus.tip0-westus.p.azurewebsites.net" }
6 REPLIES 6
Community Support Team
Community Support Team

Re: Bad request - Get User Profile

Hi @New-Bie,

 

Please share the detailed configuration of your Flow. Especailly about the fields inside the Get Profile action.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
New-Bie
Level: Powered On

Re: Bad request - Get User Profile

Here is the screenshot of the flow -

 

image.png

 

Headers information from the Outputs -

 

{
"Pragma": "no-cache",
"x-ms-request-id": "21b539e5-3e89-492e-866d-b4681c912266", "Timing-Allow-Origin": "*",
"Cache-Control": "no-cache",
"Date": "Tue, 11 Jul 2017 18:31:14 GMT",
"Set-Cookie": "ARRAffinity=a174fac1cd41aff35bbf1fc24aa22af5f8abca4644a745fa75a42a0643436723;Path=/;HttpOnly;Domain=office365usersconnectionprovider-westus.tip0-westus.p.azurewebsites.net",
"Server": "Microsoft-IIS/8.0,Microsoft-HTTPAPI/2.0",
"X-AspNet-Version": "4.0.30319",
"X-Powered-By": "ASP.NET",
"Content-Length": "146",
"Content-Type": "application/json; charset=utf-8", "Expires": "-1"
}

 

 

I tried with the Owner DisplayName as well in the Get user Profile -> User field, but the same result - NotFound.

New-Bie
Level: Powered On

Re: Bad request - Get User Profile

Can you please update me on this!

avt
Level: Powered On

Re: Bad request - Get User Profile

Bump, this appareantly happens also in start approval action (modern approvals) and send email with options (o365).

Super User
Super User

Re: Bad request - Get User Profile

has this been resolved? I hear similar issues with get user profile from coworkers ?

BigShotRob
Level: Powered On

Re: Bad request - Get User Profile

Re-create that step, if that doesn't work re-create the entire flow, I bump into this all the time with all sorts of conditions and gets, this is the solution almost all of the time.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (5,866)