cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

Building Custom Connector json body post request problem

Hi I'm developing custom connector in power automate and using it in flow were my custom connector must do post request so in json body im defining key value pairs as

 {
"{image name}":"{image in binary}"
}

 

image name is key and value is image data in bytes how to define json body request to accept both key and value pair dynamically from flow.Basically from email im recieving attachments i want to send attachment name as key and value as attachment content i'm facing problem to define json body post request to accept both key and value dynamically.When i gave manual inputs it worked fine. Can anyone help me to solve this issue.Thanks in Advance 🙂.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Dual Super User III
Dual Super User III

Re: Building Custom Connector json body post request problem

Hi @Anonymous 

 

I think you might want to change as:

 

{

"Name" : "ImageName",

"Content" : "Image Content"

}

 

and try. 

 

You can pass a string for the name and then directly pass the binary content in the content value. 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

2 REPLIES 2
Highlighted
Dual Super User III
Dual Super User III

Re: Building Custom Connector json body post request problem

Hi @Anonymous 

 

I think you might want to change as:

 

{

"Name" : "ImageName",

"Content" : "Image Content"

}

 

and try. 

 

You can pass a string for the name and then directly pass the binary content in the content value. 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Anonymous
Not applicable

Re: Building Custom Connector json body post request problem

Hi @yashag2255  Thanks for your suggestion it helped me lot.

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (4,533)