cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
djourney
New Member

Building HTTP request for a ArcGIS Rest Service

I am having trouble getting a test run from my Flow.  When I test, nothing happens! I have an ArcGIS Rest Service with a web hook enabled for any changes (New, Updated, Deleted, etc.).  I have my Request Body JSON Schema:

 

{
    "type": "object",
    "properties": {
        "$content-type": {
            "type": "string"
        },
        "$content": {
            "type": "string"
        },
        "$formdata": {
            "type": "array",
            "items": {
                "type": "object",
                "properties": {
                    "key": {
                        "type": "string"
                    },
                    "value": {
                        "type": "string"
                    }
                },
                "required": [
                    "key",
                    "value"
                ]
            }
        }
    }
}

 

 

 
 

Capture1.JPG

 

And in the next step I am trying to Parse the JSON:

djourney_0-1614099784603.png

With this schema:

 

{
    "type": "object",
    "properties": {
        "name": {
            "type": "string"
        },
        "layerId": {
            "type": "integer"
        },
        "orgId": {
            "type": "string"
        },
        "serviceName": {
            "type": "string"
        },
        "lastUpdatedTime": {
            "type": "integer"
        },
        "changesUrl": {
            "type": "string"
        },
        "events": {
            "type": "array",
            "items": {
                "type": "string"
            }
        }
    }
}

 

 

When I test manually in Power Automate and make changes to the feature service in a new window... nothing happens in Power Automate.  The ultimate goal is have an email notification sent when a change is made.  But I cannot even get PA to pick up a response to the JSON payload.  Any ideas of what I am doing wrong here?  Thank you!

 

2 REPLIES 2
PrasadAthalye
Community Champion
Community Champion

Since its an HTTP trigger, can you use Swagger OR Postman to invoke it? In the body you can pass parameters as per your schema...

Please Like and Mark this as Answer if it resolves your Issue.

Power Automate Community
RaashiSen
Community Support
Community Support

Hello @djourney ,

 

did @PrasadAthalye 's suggestion of using Swagger of POSTMAN to invoke this worked for you? If yes, please mark his response as a solution 🙂

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Users online (5,663)