cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MT090511
Frequent Visitor

Business Central Connector- Requested by User Email Content EMPTY

I noticed that in one tenant I kept getting an empty value for Requested by User Email, but when I tested this in a different environment, it worked.  I thought it was maybe because I was doing one in sandbox, and one in production. I have switched the flow to point to production instead of sandbox to test this, but still got an empty value.  It is a full user license with super permission so shouldn't be an issue there.  Has anyone come across this before?

 

NO email

MT090511_1-1618153673884.png

 

 

EMAIL

MT090511_2-1618153690807.png

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Erlandcrf
Microsoft
Microsoft

Hello @MT090511 thanks for bringing this to our attention.

 

Where this is working is the environment type "Default" or "Prod"?


Do you mean that if for example, you are using the Default (in Power Platform) and pulling information from Environment A (business central) that's not pulling the email information, but if you switch to another Power Platform environment and point to the same Environment A (on business central and retrieve the same record) then you are getting that email field back?

 

If you don't know the outcome of that scenario (using the same record from the business central), please give it a try and share the results.

 

Thanks.

View solution in original post

2 REPLIES 2
Erlandcrf
Microsoft
Microsoft

Hello @MT090511 thanks for bringing this to our attention.

 

Where this is working is the environment type "Default" or "Prod"?


Do you mean that if for example, you are using the Default (in Power Platform) and pulling information from Environment A (business central) that's not pulling the email information, but if you switch to another Power Platform environment and point to the same Environment A (on business central and retrieve the same record) then you are getting that email field back?

 

If you don't know the outcome of that scenario (using the same record from the business central), please give it a try and share the results.

 

Thanks.

View solution in original post

I didn't see this response until now, but yes that was the issue.  

Helpful resources

Announcements
MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Top Kudoed Authors
Users online (68,603)