cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New Member

Can't see files uploaded to OneDrive for Business

Hi,

 

I'm new to flow and I'm trying to create a simple flow that sends an email when a new file appears in a folder, with that file attached to the email.  When I try to select the folder for the trigger it gives me / root and then options for folders that don't actually exist in my Onedrive for Business. None of the folder I use are visible in the drop down menu. I've tried manually capturing the location for the folder (using the copy file location in Onedrive for Business) I'd like for the trigger but I can't seem to get it to work.

4 REPLIES 4

Hi @BrandonNcbSea can you please check that you have the right connection established with OneDrive? I've encountered this issue in the past where someone has accidentally connected to their OneDrive for Business instead of personal OneDrive or vice versa.

 

First of all ensure that you have the corret trigger selected (both OneDrive and OneDrive for Business exists) and that you have the correct connection. You can verify this by selecting the ellipsis on the trigger and checking the connection information.

 

If all looks good, can you please post a screenshot of your Flow to aid us with the troubleshooting.

 

If you have found this post useful, please give it a thumbs up. If it has answered your question, please accept it as the solution so others can benefit.

@MattWeston365





Did my reply help? Please give it a thumbs up.
Did I answer your question? Please mark my post as a solution!
If you liked my response, please consider giving it a thumbs up. THANKS!


Proud to be a Flownaut!





Community Leader: Black Country PowerApps & Flow User Group

Here are my connectors:

 

Here are the options it gives me.

None of those folders are in my OneDrive for Business. I don't have a personal OneDrive. Only the Onedrive for Business account for work.  I confirmed I'm using the Onedrive for Business template.

Hi @BrandonNcbSea ,

Please make sure you have selected the correct connection.

InkedCapture_LI.jpg

I have made a test on my side, it doesn't have the issue you have mentioned.

Capture5.PNGCapture4.PNG

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

that's not doing it.  Root still takes me to a folder that don't exist on the Onedrive for business for my account. I only have the one account.

Helpful resources

Announcements
PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Users online (9,067)