cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New Member

Cannot Add user to Group

Wondering if any one can help.

 

I'm trying to create a flow to add a user to a group.

But keep getting the error The template validation failed: 'The template action 'Add_user_to_group' at line '1' and column '1963' is not valid: "Unable to parse template language expression 'odata.id': expected token 'LeftParenthesis' and actual 'Dot'.".'.

 

I've tried and confirmed that using the Get-group to get id ad either Get User Profile works as does get the user from azure ad

 

But the add user to group still fails  I've tried hard coding and dynamic and doesn't work

 

Get-o365_user.jpgGet-AzureAD-User.jpg

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

Hi @wilsond3010,

 

Issue should be resolved.

Please verify if the action would work at your side:

38.PNG

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

7 REPLIES 7
Community Support
Community Support

Hi @wilsond3010,

 

Thanks for the feedback.

there is a thread reported the same issue:

https://powerusers.microsoft.com/t5/Building-Flows/Azure-AD-add-user-to-groups-Unable-to-parse-templ...

I have collected this from my side, and I will post back if I have any response back.

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Community Support
Community Support

Hi @wilsond3010,

 

Issue should be resolved.

Please verify if the action would work at your side:

38.PNG

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Thanks It's working now.

Only issue I have now it cannot use a mail-enabled group 

The issue I have going on is I cannot add to mail-enabled group as well..... Is there any timeline on microsoft's side to add this capibility? IT would assist me greatly. 

Agreed. Any ETA on a fix for this?

Any ETA on fix for adding users to groups that are mail enabled? I am currently still unable to add a user to a mail enabled group. Also even though I use the correct group ID, it doesnt seem to work with the group ID. Returns a "Invalid object identifier '" error.

Hi all,

 

I don't think a Mail-Enabled group is supported in the Add user to group action.

The workable one for the User part should be the User available in the AAD user list.

If you would like this to be added, then please submit it as an idea under the Feedback forum:

https://powerusers.microsoft.com/t5/Flow-Ideas/idb-p/FlowIdeas

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Users online (9,653)