cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Runner55552
Helper V
Helper V

Cannot Edit Flows with Microsoft Edge

As of yesterday, I am not able to edit my Flows using the Edge browser.  Still works ok in Chrome. I can see my Flows, check run history, but when I click on Edit I get an error screen. Anyone else noticing this? (see below for error message).

 

It looks like something went wrong

Please try again in a few minutes or refresh the page now.

See more details

If you contact support, you may be asked to provide the following details:

Time:
Server/Client Correlation ID: db0eb4a1-d7c2-4cc3-a6f0-817779b8d352
x-ms-client-request-id (Client->Backend Request Header): 4898b2ad-c2d6-4b50-bea8-c781-95053ed8
Error: Client request aborted
1 ACCEPTED SOLUTION

Accepted Solutions
abm
Super User
Super User

Hi @Runner55552 

 

I never had any issues when I started using the below version of Edge. Personally I found it better than Chrome as well.

 

image.png



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

View solution in original post

7 REPLIES 7
abm
Super User
Super User

Hi @Runner55552 

 

I can edit my flows in Edge & Chrome. Try to get the latest update of Edge. 

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials
Jcook
MVP

Hi,

This is cache’ing issue.
Happens to me sometimes on Edge Chromium.

I usually just switch to chrome for about half hour. Than switch back.

You can also try private mode

—Josh
If you like my post please hit the "Thumbs Up" -- If my post solved your issue please "Mark as a Solution" to help others

Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





Tried switching, coming back later, clearing cache, browsing history, etc.  Still not working. I'm on a 2018 version of Edge, will try to update.

Hello,
Any update?

Try chrome just for now

—Josh
If you like my post please hit the "Thumbs Up" -- If my post solved your issue please "Mark as a Solution" to help others

Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





abm
Super User
Super User

Hi @Runner55552 

 

I never had any issues when I started using the below version of Edge. Personally I found it better than Chrome as well.

 

image.png



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

I haven't updated Edge yet, but plan to give that a try.

Thanks, installing latest version of Edge solved it.

Helpful resources

Announcements
Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (2,211)