cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
tomassan
New Member

Cannot open link in approval e-mail

I'm testing out an automated approval. When a file is added to a folder in a Team Sharepoint site in Microsoft Teams of which I am the owner, an approval e-mail is sent. Currently I'm testing with sending it to myself. There is a link to the file as it should be, but when I click it, I get a message stating:

 

401 - Unauthorized: Access is denied due to invalid credentials.

You do not have permission to view this directory or page using the credentials that you supplied.

 

Any clues how to get this working?

4 REPLIES 4
v-xida-msft
Community Support
Community Support

Hi @tomassan,

 

Could you please share a screenshot of your flow's configuration?

 

The error message told that you don't have enough permission to access this link (Link to item dynamic content) using the credentials that you supplied currently.

 

I have made a test on my side and don't have the issue that you mentioned. My flow's configuration as below:30.JPG

The flow works successfully as below:31.JPG

 

When clicking the link within above screenshot, the file (A picture) opens well as below:32.JPG

 

 

Only people with permissions will be able to access the Link to Item dynamic content, if you first access the link within the browser, a Microsoft login dialog would be shown up as below and ask you to select an account to provide credentials for accessing this link:33.JPG

 

 

Please check if the credentials that you supplied currently have enough permissions to access this link. If the people don't have permissions to access this SharePoint Site (Library), they could not access the link.

 

In addition, please consider take a try to clear cache of your browser and access the link within that browser using your credentials, then check if the issue is solved on your side.

 

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi guys,

 

did you ever find a fix for this as i have the same issue.

 

It doesnt seem to be related to the flow as such, as the approval/reject link works fine in either Chrome or Firefox.

 

I only get the below error message when the link opens in IE (which is most users default browser)

 

flow error.JPG

Actually ive found the workaround on this issue that im seeing. 

 

If i disable Compatibilty View in IE for Intranet sites then the link works fine - bit of a pain!

flow error2.JPG

 

Hope this helps.

GabrielStJohn
Microsoft
Microsoft

Hello, @tomassan!

Thank you for posting on the Flow Community Forum! Have you had an opportunity to apply @safoster‘s recommendation to adapt your Flow? If yes, and you find that solution to be satisfactory, please go ahead and click “Accept as Solution” so that this thread will be marked for other users to easily identify!

Thank you for being an active member of the Flow Community!

-Gabriel
Flow Community Manager

- Gabriel
Community Manager
Power Automate | Power Virtual Agents
Super User Program Manager



Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Users online (1,102)