cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Cannot post description of a site page to a adaptive card/shorten JSON value

I have a flow that takes file properties (SharePoint site page) and use its values (description, title, author etc). to populate an "adaptive card" JSON template. Everything works - title, author and so on except description. I assume its because the description is to large. I get the following error:

 

"The specified Teams flowbot adaptive card request is missing or invalid. The tracking Id is '87280857-bb63-4d55-99d3-fe216b0a0411'."

 

I put the description in a TextBlock:

 

{
"type": "TextBlock",
"text": "@{body('Get_file_properties')?['Description']}",
"wrap": true
},

 

Does not work.

 

 

I have tried to shorten via substring it but I get an error "the expression is invalid". My expression:

@{body('Get_file_properties')?['Description']}.substring(1,50)

 

Above does not work. How can I shorten the JSON value? And could it be another/different issue why the flow isnt working when I try to load the adaptive card JSON with the description of my file?

AdaptiveCard.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Microsoft
Microsoft

Re: Cannot post description of a site page to a adaptive card/shorten JSON value

@Akourt 

 

Seems like the formula that you are using for the substring is incorrect.

 

The format for substring in flow is substring(text,start index,end index)

 

Could you please try using the above formula for substring and  check if that helps.

I think there is limit for the description on the amount of text that you can enter I'm not exactly sure on the number of characters that you use of.

 

If this information helps you, please hit the like button and mark the solution as resolved, so that it will help other users in future.

 

 

View solution in original post

1 REPLY 1
Highlighted
Microsoft
Microsoft

Re: Cannot post description of a site page to a adaptive card/shorten JSON value

@Akourt 

 

Seems like the formula that you are using for the substring is incorrect.

 

The format for substring in flow is substring(text,start index,end index)

 

Could you please try using the above formula for substring and  check if that helps.

I think there is limit for the description on the amount of text that you can enter I'm not exactly sure on the number of characters that you use of.

 

If this information helps you, please hit the like button and mark the solution as resolved, so that it will help other users in future.

 

 

View solution in original post

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (6,038)