cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Changes to how approvals work is getting frustrating

Hi folks, 

 

If you have start and approval and start and approval V2 steps then leave V1 exactly as it was. Start an approval V1 is gone and is now 'Start and wait for an approval' 

 

What has now seemingly changed is I can't get the dynamic content from the approval step to put into an email like comments on the approval and more importantly who approved it, because it's changed by itself to be part of an apply to each step.  See the screenshot below. 

 

Capture.JPG

Why can't I get dynamic content from the approval? 

 

I've posted about this before where I discovered my flows had actually changed by themselves where all of my start an approval steps are now in these 'apply to each steps'.

 

Now trying to make a flow for an approval and having things like the above happen, it's getting frustrating whereas before it was so simple. 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

Hi @Anonymous ,

 

Could you share a full screenshot of Flow configurations?

It seems that this situation has nothing to do with the new additions to Approval.

If you use Get items action and use Link to item in Approval action, Apply to each will automatically appear, it needs to iterate through all the items.

And if Approval action is configured in Apply to each, only the actions that are also included in Apply to each can use the action related to Approval action.

You could try to move Send an email action to Apply to each and you would use Dynamic content.

19.PNG

Also if you only want to get the contents of a single item, you could use Get item action instead of Get items action.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
Community Support
Community Support

Hi @Anonymous ,

 

Could you share a full screenshot of Flow configurations?

It seems that this situation has nothing to do with the new additions to Approval.

If you use Get items action and use Link to item in Approval action, Apply to each will automatically appear, it needs to iterate through all the items.

And if Approval action is configured in Apply to each, only the actions that are also included in Apply to each can use the action related to Approval action.

You could try to move Send an email action to Apply to each and you would use Dynamic content.

19.PNG

Also if you only want to get the contents of a single item, you could use Get item action instead of Get items action.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Users online (4,478)