cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Andrew0228
Helper I
Helper I

Column 'F010055' does not exist. It may have been deleted by another user.

Hello,

 

I am trying to create a flow that populates somebody's first name, last name, and supervisor from a separate lookup list. It works as follows. When an item is created in the one list it will get an item from the Employee Lookup list I have made. We have employee numbers that look '999999', but also have employee numbers that look like 'F99999'. The flow works perfectly for all number employee numbers and when one with a letter is used I get the error message "Column 'F010055' does not exist. It may have been deleted by another user." Is there a reason it is seeing this as a column now? Is it because I am using the title column?

Andrew0228_0-1614314652353.png

Andrew0228_1-1614315079759.png

 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
v-litu-msft
Community Support
Community Support

Hi @Andrew0228,

 

When the column name in the filter query is not correct, it will report the error you met.

If the column name of SharePoint has been modified, the system name of Column wouldn't be modified. When we append it into filter query, it should be system name. 

If you want to get the column system name, you could go to SharePoint Setting-> List setting->Column Name->Column Detail:

Screenshot 2021-02-26 172126.jpg

 

Screenshot 2021-02-26 172200.jpg

 

Screenshot 2021-02-26 172246.jpg

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

OliverR-82
Resolver II
Resolver II

Alright, I'm on the laptop now. So, just to be clear @Andrew0228 , what I think your filter query should look like is the following:

OliverR-82_0-1615017353035.png

Notice the single quotes around the string expression. Written out in full it would look as follows:

 

EmployeeNo eq 'string(triggerbody()?['Title'])'

 

 I think that should work.

View solution in original post

9 REPLIES 9
v-litu-msft
Community Support
Community Support

Hi @Andrew0228,

 

When the column name in the filter query is not correct, it will report the error you met.

If the column name of SharePoint has been modified, the system name of Column wouldn't be modified. When we append it into filter query, it should be system name. 

If you want to get the column system name, you could go to SharePoint Setting-> List setting->Column Name->Column Detail:

Screenshot 2021-02-26 172126.jpg

 

Screenshot 2021-02-26 172200.jpg

 

Screenshot 2021-02-26 172246.jpg

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

The Column Name has not changed, the issue only arises when there is a letter in the string.

OliverR-82
Resolver II
Resolver II

Why is @v-litu-msft 's reply marked as "Solution" when it is not a solution and answering besides the question?

@Andrew0228 I suspect the problem may be that you have your Odata filter backwards. I think it should be: 

Title eq EmployeeNo

You have it the other way around, which means it will look for a Column with the name of EmployeeNo.

The fact that it does work with all-number employeenumbers is a bit strange, though, but give my suggestion a try anyway.

Hi @Andrew0228 , I was wrong in my previous post, I misunderstood how your lists were structured.

The problem is if there's a letter in the employee number then you are evaluating a string. In that case you should put single quotes around the 'Title' field in your filter query of the Get Items action.

Now, seeing as the query does work if the employee number does not contain a letter (because in that case it's a number and thus quotes aren't needed in the query expression), I would suggest to convert the dynamic value to a string in your query expression. I'm on my phone now so can't type it out properly. Let me know if you're not sure what I mean.

OliverR-82
Resolver II
Resolver II

Alright, I'm on the laptop now. So, just to be clear @Andrew0228 , what I think your filter query should look like is the following:

OliverR-82_0-1615017353035.png

Notice the single quotes around the string expression. Written out in full it would look as follows:

 

EmployeeNo eq 'string(triggerbody()?['Title'])'

 

 I think that should work.

View solution in original post

It worked perfectly! Thank you @OliverR-82 

Deaddog
New Member

I'm getting this "Column 'F010055" error and following all solutions on this forum, but it still persists.  

How it should work

When adding a new list item to the 'Project List' list, a folder gets created in a library called 'Drawing Files' library.  The hyper link should get added to the 'Project List' list on a column called 'Link' .

 How it actually works

All flows are working well except for the last flow "Send HTTP Request to Sharepoint".  This flow should add the library item hyperlink to the 'Link' column on the list.

 

See screenshots, please help.   -Thanks

 

Deaddog_0-1627720989840.png

 
 

2021-07-31_10-45-31.png

 

 

Hi @Deaddog ,

Actually, the error you're getting is a different one from the one that's discussed in this thread.

From the error description it looks like the item that you're trying to update does not exist. But, sometimes error messages aren't very accurate, so maybe that's not the problem.

In your screenshot I can see that you seem to be missing a closing single quote (') after your "link to item" field. Can you verify that you have enclosed the field in quotes?

Also, I'm not sure if this is really required in this case, but I always include an 'ACCEPT' header in my HTTP calls with a value of "application/json;odata=verbose". Someone correct me if that is not needed here. But it doesn't hurt to include it in any case.

Thx OliverR,

After cleaning up that single quote and changing the ID to the "When an item is created" ID, the flow works. 🙂

Case Closed!

2021-08-03_08-37-12.png

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,535)