cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Lauren_
Level: Powered On

[Column] is equal to [value] not working (condition)

Hi everyone, I really am struggling with Flow conditions - I'm trying to tell Flow, if [this column (Yes/No)] contains [this], follow this action line, but it either fails or acknowledges it incorrectly. For example, my Flow says ...

1.jpg

The details of the list item in this column state YES in the List and TRUE in the imported information. Yet this Flow is failing!


2.jpg3.jpg

 

 

 

 

 

 

 

If I change my Flow condition from TRUE to YES, it works but says that this value is FALSE. What on earth am I doing wrong?

5 REPLIES 5
Highlighted
Lauren_
Level: Powered On

Re: [Column] is equal to [value] not working (condition)

Frustratingly, I've tried it by copying an old Flow and using the old-style condition with exactly the same information and it works.

1.jpg

Advanced mode code is:

@equals(items('Apply_to_each')?['TL_x0020_Escalate'], true)

But I can't put this into the new Flow condition in Expression as it's apparently invalid.

Community Support Team
Community Support Team

Re: [Column] is equal to [value] not working (condition)

HI @Lauren_ ,

 

According to your description, TL Escalate is a Yes/No column in SharePoint list. And you want to check if the escalate selection is equal to Yes.

 

I have made a simple flow likes below, the condition is configured likes below, which is working fine.

1.PNG2.PNG

 

Here is a doc on building advanced condition, please check it for a reference:

https://flow.microsoft.com/en-us/blog/build-more-powerful-conditions-in-flows-and-more/

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Lauren_
Level: Powered On

Re: [Column] is equal to [value] not working (condition)

Hi Mabel, for some reason on my List/Flow it is not functioning the way it should - please see the below image.

1.jpg

I added an item to the list with TRUE/YES in the TL Escalate column, Flow acknowledges it as FALSE in the outputs and the condition reads it as FALSE.

Lauren_
Level: Powered On

Re: [Column] is equal to [value] not working (condition)

Frustratingly, I've now gotten to the point of rebuilding this Flow a couple of times and seen this behaviour repeat a couple of times -- it's erratic but so far have one Flow that is reading the column value correctly (thus far). I can't see why this is happening.

Community Support Team
Community Support Team

Re: [Column] is equal to [value] not working (condition)

Hi @Lauren_ ,

 

The issue could not be reproduced by me.

 

Please share a URL to the flow which doesn’t work as expected, and an image on the SharePoint list setting.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (5,693)