cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
EdviconEdu
Advocate I
Advocate I

Condition Check Failure (Approval)

I have a bit of advanced flow. Conditions worked fine until it goes for around 10 steps in the flow. But once I started adding more connectors to the flow, conditions started working in the opposite way.

 

Ex: Condition I added for approval:

The response is equal to Approve 

  • For Yes side: It runs when Reject the approval request
  • For No side: It runs when Approve the approval request

Then I have to edit and change the condition to "is not equal to". Then when I approve, it approves by going into Yes side. Does this make sense?

Also, if I edit the flow later, to add/ update anything else, flow again works fine. Means, I have to change that "is not equal to" again back to "is equal to".

 

This is not what should be happening. 'Yes' part should run when Approve. This works fine for my small flows. Please check.

 

This bug is failing our systems over and over again. Reported before. No action has been taken.

1 ACCEPTED SOLUTION

Accepted Solutions
ekarim2020
Super User
Super User

Use Outcome for your condition, as this gives you entire outcome of the approval. Your approval can be sent to many approvers but we are not interested in the individual responses, we only want to know the final outcome.

ekarim2020_1-1628417159254.png


Ellis
____________________________________
If I have answered your question, please mark the post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

8 REPLIES 8
ekarim2020
Super User
Super User

Please could you post the clear screen shots of your flow to help understand what is going on.

Ellis

Screenshot 2021-08-08 145455.png

This is what I am experiencing. Because of that, I have to set the condition "Is not equal to" te get the flow works correctly. Apologies for the text, I wrote using mouse. 🙂

Again if I edit and update anywhere in the flow at a later time, the flow goes back to working correctly. Then I have to change the condition back to "is equal to" where it should be the one in the first place. 

The funny part is, if I update again, I have to set the condition to "is not equal to", to get the flow again works.

 

See, how hard this is. I don't know why they didn't find this bug. 

 

FYI: Flow is designed correctly. I've other small flows where this approval works very fine. But all my flows with more steps face this issue.

 

Thanks.

ekarim2020
Super User
Super User

Use Outcome for your condition, as this gives you entire outcome of the approval. Your approval can be sent to many approvers but we are not interested in the individual responses, we only want to know the final outcome.

ekarim2020_1-1628417159254.png


Ellis
____________________________________
If I have answered your question, please mark the post as Solved.
If you like my response, please give it a Thumbs Up.

Hi @ekarim2020,

I will set this condition and monitor for the next few days, and let you know. If this works as expected, will mark your suggestion as the solution. 🙂  

Hi @ekarim2020,

 

Thank you for the suggestion. It seems all flows are working fine as expected. We made several edits to the flows and didn't get issues like before. 

 

BR,

Nimesh 

Chidung
New Member

Hi everyone, sorry to dig up this topic but I'm having trouble with a condition check.

I'm creating a workflow for leave requests and what I want to do is if the value of the leave category is either a holiday (Public, religious, company) or a Birthday then I don't need to receive the approval.

Chidung_0-1658152292965.png

Here's the condition (I use Category value as the trigger) :

Chidung_2-1658152404329.png

I tried the opposite, putting the text between apostrophe, with just one condition but I receive the approval regardless and the If no scenario never plays out.

 

Anyone has an idea ?
Many thanks.

Hi @Chidung 

 

Please try the following condition, using the And operator:

Snag_f1ca6b1.png


Ellis
____________________________________
If I have answered your question, please mark the post as Solved.
If you like my response, please give it a Thumbs Up.

Hi Ellis and thank you for taking the time to answer !

Seems like it's working fine with your conditions after several tests and I have to say I wouldn't have thought of that.

 

Many thanks.

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (3,601)