cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
DarenD
Level: Powered On

Condition Issue with Simple Text

Team,

   I've got a simple FLOW that's simply supposed to check to see if the text in a list field contains "High-Five" in it upon creation.  If yes, then send one e-mail, if not then send another. However, I keep getting the "no" option no matter what's in the text field.   I've check everywhere and I think my syntax is correct but apparently not. Could use some help working it out.  Here's the code and the screen shot:

 

@contains(triggerBody()?['E_x002d_Card_x0020_Type'], 'High-Five')

 

EAR-Notice-FLOW-Error.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Condition Issue with Simple Text

Hi @DarenD,

 

Could you please share more details about the field that you mentioned which contains value "High-Five"?What is the name of the field and what is the type of the field.

 

I have made a test on my side to create a "E_Card Type" column with a single line of text type in my list.

You could add a Compose action under the trigger to get the value of the field when an item is created, and the screenshot of the flow as below:

 Capture.PNG

 

 Then please pay attention to the value of Compose action when the flow runs.If the value of the field contain "High-Five", the flow would run successfully as below:

Capture.PNG

 

Please check the value in the Compose field to see if the value contain "High-Five", if no, please share the screenshot of the full run history and more details about the field in the list so we would try to provide a proper workaround for you.

 

Best regards,

Alice

View solution in original post

6 REPLIES 6
Community Support Team
Community Support Team

Re: Condition Issue with Simple Text

Hi @DarenD,

 

Could you please share more details about the field that you mentioned which contains value "High-Five"?What is the name of the field and what is the type of the field.

 

I have made a test on my side to create a "E_Card Type" column with a single line of text type in my list.

You could add a Compose action under the trigger to get the value of the field when an item is created, and the screenshot of the flow as below:

 Capture.PNG

 

 Then please pay attention to the value of Compose action when the flow runs.If the value of the field contain "High-Five", the flow would run successfully as below:

Capture.PNG

 

Please check the value in the Compose field to see if the value contain "High-Five", if no, please share the screenshot of the full run history and more details about the field in the list so we would try to provide a proper workaround for you.

 

Best regards,

Alice

View solution in original post

DarenD
Level: Powered On

Re: Condition Issue with Simple Text

Alice,  Thank you very much for the great reply!!  The E-Card Type field is a simple SharePoint dropdown text field.  I did add the compose, still didn't run. How did you get the "output" to show so I can error check?

EAR Compose.png

Community Support Team
Community Support Team

Re: Condition Issue with Simple Text

Hi @DarenD,

 

If the E-Card Type field is a SharePoint dropdown text field, please choose the "E-Card Type Value" dynamic content in the Compose.

 

Best regards,

Alice

DarenD
Level: Powered On

Re: Condition Issue with Simple Text

That worked like a champ! Thank you very, very much!  

 

If you know how to determine if a date field is blank or not...that would be wonderful! 

 

Thanks

D

DarenD
Level: Powered On

Re: Condition Issue with Simple Text

Alice,

  Here's the URL to my post https://powerusers.microsoft.com/t5/Building-Flows/Follow-Up-Date-Error-w-Blank-Date-Field/m-p/17216...

 

If you have some time I would appreciate any help.

 

Thanks

D

mgallagh
Level: Power Up

Re: Condition Issue with Simple Text

Hey,

 

I was hoping you could take a look at a similar issue I am having w/ condition based logic to drive 2 different emails. My logic is based on the value of a from the drop-down field. Here's the error I am seeing:

 

vnext-flow-error.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

And here is a screenshot of the flow set-up:

 

vnext-flow-screenshot.png

Helpful resources

Announcements
firstImage

Power Platform Online Conference

Speakers, submit your sessions now! Call for speakers ends Feb. 10!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (4,096)