cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
laura_marsden
Regular Visitor

Condition always returning false

Hi experts,

 

I've searched through the community pages to see if I can find the same issue and resolution to my problem but have been unable to find an answer to fix my exact problem. 

 

I have created a copy of a flow to test out some changes to a test SharePoint form which it gets it's responses from, so that I don't break the one that is currently working. After updating some of the form questions I have come to the flow to test it works.

 

When I run it the condition is always setting as FALSE, however there are are attachments. 

 

See screenshots of flow below:

 

laura_marsden_0-1655078992555.png

So this is a copy of a flow that is already working, however I have updated the Parse JSON Content field to 'Attachments If' to get response from this detail, as this question was updated in the form.

laura_marsden_1-1655079040120.png

I also updated the File path in Get file content using path, to link to the test form.

laura_marsden_2-1655079113934.png

laura_marsden_3-1655079161627.png

 

I have no idea why this is not working. Everything else is working as expected except the attachments. 

 

Hoping someone can help. 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Pstork1
Dual Super User
Dual Super User

If you updated the Form questions you will need to wait for about 24 hours or delete and recreate the connection from scratch to get it to pick up changes made in the backend data source.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Join me at 365EduCon in Chicago on Sept. 26-30 where I'll be presenting on the Power Platform!

View solution in original post

2 REPLIES 2
Pstork1
Dual Super User
Dual Super User

If you updated the Form questions you will need to wait for about 24 hours or delete and recreate the connection from scratch to get it to pick up changes made in the backend data source.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Join me at 365EduCon in Chicago on Sept. 26-30 where I'll be presenting on the Power Platform!
laura_marsden
Regular Visitor

@Pstork1 Yep, I realised after more tests that the connection to the form was not correct. 

 

I updated the Condition- formula for Empty connection was not directing to the correct (file) part of the form. 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Super User 2 - 2022 Congratulations 768x460.png

Welcome Super Users

The Super User program for 2022- Season 2 has kicked off!

Users online (2,648)