cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
LorisCavalli
New Member

Condition check a Chioce

I'm starting with Power Automate but I don't understand why my flow doesn't give errors but the condition is always false.

I check the contents of a SharePoint List column defined as Choice, maybe that's the problem?

LorisCavalli_0-1651771836022.png

It is in Italian but I think that the problem is still understandable.
Here below the Flow options:

LorisCavalli_1-1651771961369.png

And here below the condition always "False" 😞

LorisCavalli_2-1651772052520.png

Where am I wrong let me understand.
Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
v-yujincui-msft
Community Support
Community Support

Hi @LorisCavalli ,

 

It seems to be caused by the dynamic content you are using.

vyujincuimsft_0-1652064033431.png

vyujincuimsft_1-1652064058392.png

Maybe you could try to Select Dynamic content with 'Value'(Region Value).

vyujincuimsft_2-1652064748571.png

vyujincuimsft_3-1652064800464.png

In addition, you could consider adding a Compose action before the Condition Action to see if the corresponding output is correct.

vyujincuimsft_4-1652065000380.png

vyujincuimsft_5-1652065585281.png

 

 

Best Regards,
Charlie Choi

View solution in original post

4 REPLIES 4
Rhiassuring
Super User
Super User

Hello @LorisCavalli !

Sometimes, this all happens because of a space that is hard to see. 

Can you check the following for me?

 

1) From a recent run of the flow, check (and if you could, screenshot please) the section from the initial trigger output where you can see "EUR" - I see it in your list, but it might have some weird encoding coming through. 

 

2) In your condition, it seems silly, but please be sure there is no trailing space on your EUR. It happens to the best of us.

 

Cheers,

 

Rhia

______________________________________________________________


Did this answer your question? Please mark it as the solution.
Did it contribute positively towards finding the final solution? Please give it a thumbs up.

I answer questions on the forum for 2-3 hours every Thursday!



LorisCavalli
New Member

Thanks for the answer, I have checked from both sides but I don't see spaces of any kind.

LorisCavalli_0-1651828783540.pngLorisCavalli_1-1651828866971.png

 

What could I do, alternatively?

v-yujincui-msft
Community Support
Community Support

Hi @LorisCavalli ,

 

It seems to be caused by the dynamic content you are using.

vyujincuimsft_0-1652064033431.png

vyujincuimsft_1-1652064058392.png

Maybe you could try to Select Dynamic content with 'Value'(Region Value).

vyujincuimsft_2-1652064748571.png

vyujincuimsft_3-1652064800464.png

In addition, you could consider adding a Compose action before the Condition Action to see if the corresponding output is correct.

vyujincuimsft_4-1652065000380.png

vyujincuimsft_5-1652065585281.png

 

 

Best Regards,
Charlie Choi

Your suggestions allowed me to solve the problem thanks. 🙏

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Difinity Conference 2022

Difinity Conference 2022

Register today for two amazing days of learning, featuring intensive learning sessions across multiple tracks, led by engaging and dynamic experts.

European SharePoint Conference

European SharePoint Conference

The European SharePoint Conference returns live and in-person November 28-December 1 with 4 Microsoft Keynotes, 9 Tutorials, and 120 Sessions.

Users online (1,908)