cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ahmadbutt
Helper IV
Helper IV

Condition is not working, it is always false... (Microsoft Forms to SharePoint item)

- Without the condition the Flow creates a SharePoint item from Microsoft Forms. So this part works good.

- The condition; id-test(Microsoft ID) is the same as Id-test(SharePoint item) does't work, see condition.

Someone got a idea to let it work?

forms1.PNGFlow2.PNG

37 REPLIES 37

Hey @v-litu-msft 

Would that not error if the array was null as the length expression expects a value?

You could use the empty() expression instead?

1.pngHTH

Jay

@Jay-Encodian This also gives the same error.

- false = working = creating a item.

- true = not working...

@ahmadbutt 

What does not working mean? what;s happening... can we have some screen shots.

That expression definitely works... I've just built a flow using it.

HTH

Jay

@Jay-Encodian creating a item works. But updating a item doesn't work. 

- when a Form is created with a new ID than it created a new item.

- when a Form is modified with the same ID than it isn't updating the item.

1e.PNG

@ahmadbutt 

OK, but is the expression now working which was the previous issue?

@Jay-Encodian The condition with True and False was not working. Now it works with False but not with True..

@ahmadbutt 

The expresion is working... but the first action inside the 'False' branch is not working? Which means the expression is working but you have an issue with the 'Update Item' action.

Sorry, I'm not trying to be pedantic... but we need to understand where the issue lies.

Thanks J

@Jay-Encodian There is something wrong with the Update item.. I think It is the 'Id'. I don't know what to fill in there. I tried the 2 things shown in the picture (Id and list of ..... Id). If I do list of ..... Id than it created a new row instead of updating the row.1e.PNG

@ahmadbutt 

That should be the 'Id' column from the 'Get Items' action... note Flow will automatically add an 'Apply to Each' loop as the 'Get Items' action returns and array...

HTH

Jay

Now the update item works but it adds a row extra with it.. It should only update the row.1e.PNG

--2e.PNG

@ahmadbutt 

Is there more than one item returned in your Get Items action?

@Jay-Encodian This I got in get items: (Id-test is from the Form I fill in, so it is just one id)

1e.PNG

@ahmadbutt 

Can you please check the run history to verify what is returned? Showing the query doesn't check what data was actually sent back 😉

Do you mean this?

3e.PNG

@ahmadbuttyes, check the body data as every item in the array will be processed by your 'Update File' action

@Jay-Encodian Uhm I don't know what u mean. It is updating the item but it adds the same item again in SharePoint. From the body I can see that it works?

4e.PNG

@ahmadbutt 

The 'Get Items' action could return multiple items... if it did your 'Update Item' would run multiple times.

I was asking you to check the 'Body' value of the 'Get Items' action to verify the number of items returned... you could also page through the... but to do is the simple way just check how many times the 'Apply to each' loop has run.

A.png

 

View solution in original post

@Jay-Encodian @v-litu-msft @manuelstgomes The problem was that I had 2 flows open with the same Flow. I had copied it.. So the flows ran 2 times. I turned 1 Flow off and that was the problem. Sorry for this.... and thanks for the help again.

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,185)