cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Condition isn't working anymore

Hello,

I made a couple of flows.

 

1. When an item is created in LIST A --> make an item in LIST B

2. When an item is edited in LIST A --> Edit the corresponding item in LIST B

3. When an item is deleted from LIST A --> Delete corresponding item in LIST B

 

In the first flow I add the ID of the item in LIST A (in sharepoint) to a field "CreaID" in LIST B (also in SharePoint).

In the last 2 flows I do the following:

- when an item or file is edited in LIST A

- Get items from LIST B (I also changed te settings to pagination and more than 100 items in settings)

-  Condition if "CreaId" (LIST B) is equal to "Id" (LIST A)

- If Yes --> edit Item in LIST B.

 

Everything worked fine with my test data. When I entered a lot of items (165) in LIST A (with copy paste), my first flow worked. All the items were also added in LIST B. However my other 2 flows don't work anymore.

 

If I run a test I see he retrieves all the Items from LIST B. The checking of the condition takes more than a minute. And the result is false.  Picture of result in attachment.

 

What can be wrong?

2 REPLIES 2
Hardesh15
Super User
Super User

@Anonymous  Why are you creating 3 flows here? you can achieve this via one flow. Also where is your flow screens.

Please 'Thumbs Up' the posts that helped you and 'Mark as Solution' if my post answered your question.

@Hardesh /Gopenly.in

Anonymous
Not applicable

hello,

I don't work with Power automate that often. 3 flows was the only way I could think of. I'm going to close the topic since flows seem to work again although nothing changed...

Thanks for the reply.

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Users online (5,365)