cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

Configure run after not working anymore

Good day,

 

I have a fairly large flow with multiple conditions.  I used the 'Get file metadata using path' Action to check if a certain Word document exists.  If the Document exists, the Flow will copy all Metadata to the PDF File with the same name - This is working.  When a PDF File is uploaded, the same process is followed.  The Flow will try and query the Word Document by name and fail - With the 'Configure run after' Action set to Succeeded and Failed the flow succeeded and sent an email notifying the user that there is no Word Document/Properties to update the PDF with.

 

This used to work properly but all of the sudden I get the error message that The file ..../sites/test/Test 1.docx does not exist.  I know it does not exist, hence why I set the following actions to run if the previous step was successful or not.

FlowError.PNG

 

Any help would be appreciated.

 

 

Regards,

3 REPLIES 3
Highlighted
Dual Super User
Dual Super User

Re: Configure run after not working anymore

Hi @heinrichbenade 

 

The flow is failing in Condition - Check PDF Site URL and doc type properties

What is the subsequent action after that and is it handling failed errors?

 

 

Regards,

Reza Dorrani

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

Highlighted
Advocate I
Advocate I

Re: Configure run after not working anymore

Thank you @RezaDorrani,

 

The issue was with the Send Mail Action.  When inserting a HTML hyperlink, it changes some of the tags:

html.PNG

 

When editing the email body later again, the hyperlink appears like the below:

HTML Tag error.PNG

 

After removing the HTML hyperlink from the Body of the email, the Flow finished without any errors.

 

The thing that caught my attention was that the error message Flow displayed was that the file does not exist.  But the actual error occured within the send mail action.

 

Thanks for the reply.

 

 

Kind Regards, 

Highlighted
Dual Super User
Dual Super User

Re: Configure run after not working anymore

Hi @heinrichbenade 

 

Glad to know it worked out 

 

Regards,

Reza Dorrani

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

Helpful resources

Announcements
FirstImage

Microsoft Ignite 2020

Check out the announcement of Power Platform content at Microsoft Ignite!

thirdImage

Experience what's new for Power Automate

Join us for an in-depth look at the new Power Automate features and capabilities at the free Microsoft Business Applications Launch Event.

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (5,105)