cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
KIBANG
Helper II
Helper II

Converted time in flow is off by three hours

I have set up a flow where a new calendar event is created when a sharepoint list (new meeting request) is created. I have set up convert time zone functions but the time is still off by three hours. For example, I created a meeting request with start and end time from 12:00 PM - 1:00 PM, but the calendar invite has 3:00 PM - 4:00 PM. Not sure what I am doing wrong. I have included a screenshot for reference.

Calendar invite flow converted time.png 

2 ACCEPTED SOLUTIONS

Accepted Solutions
Pstork1
Dual Super User III
Dual Super User III

Use the "Gear Menu" in the upper right corner of the site.  Go to Site Information and at the bottom click the link for View All Site Settings.  In Site Settings click on the Regional Settings Link under Site Administration.  You will see something like this.

image.png



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

Pstork1,

 

Thank you! It was as you suspected. The regional time was set to PST. 

View solution in original post

4 REPLIES 4
Pstork1
Dual Super User III
Dual Super User III

When working with dates and times in SharePoint you need to adjust the time for the time zone that the SharePoint data center is running in, not just your local time.  Check the time zone settings for the SharePoint site collection and I think you will find it is 3 hours off your local time zone.  For example, local time zone US East and SharePoint time zone Pacific.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Thanks for the tip. I am trying to see what time zone is set for the site, but I don't see where this information is. I looked it up, and one site is telling me to go to site administration > regional settings, but all I see under site administration is lists and libraries. 

Pstork1
Dual Super User III
Dual Super User III

Use the "Gear Menu" in the upper right corner of the site.  Go to Site Information and at the bottom click the link for View All Site Settings.  In Site Settings click on the Regional Settings Link under Site Administration.  You will see something like this.

image.png



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

Pstork1,

 

Thank you! It was as you suspected. The regional time was set to PST. 

View solution in original post

Helpful resources

Announcements
MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (83,161)