cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Copying SharePoint to On premise failing on name

While I may be new to MSFT Flows/Power Automate, I am not a newbie (PowerShell Pro, SC Orchestrator Pro). I am attempting to build a simple task that takes an email attachment and saves it to SharePoint (personal flow part) it to SharePoint. This works fine. The second part takes the file from SharePoint and moves it locally to an AD server to be processed by a PowerShell script. I used the built in template and constructed one as well. It gets stuck on a weird part. It gets back a 400 (bad request on creating the file. The data in the log shows the correct input:

 

Folder path


\\wwh-asr-dc\Ultipro\

 

File name

 

Active_EEs_Only.csv

 

I have tried both using the file name of the existing SharePoint file, as well as giving it a new name (that is what is above), yet the actual error is more bizarre:

 

Body

 

  "status": 400,
  "message": "The requested action could not be completed. Check your request parameters to make sure the path '\\\\wwh-asr-dc\\Ultipro\\/Active_EEs_Only.csv' exists on your file system.\r\nclientRequestId: 479dfda6-0ca7-43c8-aa2a-428c8e5e1461",
  "error": {
    "message": "The requested action could not be completed. Check your request parameters to make sure the path '\\\\wwh-asr-dc\\Ultipro\\/Active_EEs_Only.csv' exists on your file system."
  }

 

 Notice the extra '/' inserted between the folder path and filename? Nowhere in the log does it show to create this. I have tried declaring the complete path in the name as well (not allowed). Why is a stock flow template and one I build from scratch doing the same exact thing, when the inputs aren't matching the outputs? Obviously, Windows will not allow a '/' in a filename.

 

Thoughts?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
New Member

Re: Copying SharePoint to On premise failing on name

OK, so I did finally figure it out. Gateway as I stated was fine. Connector was fine. Issue was stupidity on my part and part of previous admins. Some previous admin thought we need to migrate domain names for some odd reason and had set up a secondary domain, that has only a few servers on it. We have a single server that replicates our domain to AAD, and I felt this was the best place to add the gateway, as it is basically the same function. Turns out that server is actually on the other domain (even though its sole job is to sync the current, active domain to AAD). So, obviously, I needed to declare the FQDN of the share in the connector and in the flow.

 

So sorry to those that may find this in the future thinking they have found their problem. You most likely have not, as you shouldn't have some a odd setup.

 

 

View solution in original post

6 REPLIES 6
Highlighted
Microsoft
Microsoft

Re: Copying SharePoint to On premise failing on name

Hi @RaoulDuke,

 

Could you please provide an screenshot of the Flow and specifically of the component or components you are using for creating the path. I want to see the configuration of the path. 

 

Highlighted
New Member

Re: Copying SharePoint to On premise failing on name

Not sure what good it will do, but here you go:

 

RaoulDuke_0-1596233187148.png

 

Highlighted
Super User III
Super User III

Re: Copying SharePoint to On premise failing on name

Hi @RaoulDuke 

 

Did you selected the path using the browse.

 

image.png

 

Also make sure you installed the gateway and configured the connection

 

image.png

Please see this article

 

https://powerusers.microsoft.com/t5/Building-Flows/Save-email-attachment-to-network-drive/td-p/30993...

 

 



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

Power Automate Video Tutorials
Highlighted
Microsoft
Microsoft

Re: Copying SharePoint to On premise failing on name

Thanks @abm. Yes please @RaoulDuke check the gateway because I have created a new gateway to my machine and is working fine, with the same configuration you have. I don't have access to upload images, but please check the gateway because regardless if you are typing the path manually or using the browse button is working fine.

 

 

Highlighted
New Member

Re: Copying SharePoint to On premise failing on name

OK, so I did finally figure it out. Gateway as I stated was fine. Connector was fine. Issue was stupidity on my part and part of previous admins. Some previous admin thought we need to migrate domain names for some odd reason and had set up a secondary domain, that has only a few servers on it. We have a single server that replicates our domain to AAD, and I felt this was the best place to add the gateway, as it is basically the same function. Turns out that server is actually on the other domain (even though its sole job is to sync the current, active domain to AAD). So, obviously, I needed to declare the FQDN of the share in the connector and in the flow.

 

So sorry to those that may find this in the future thinking they have found their problem. You most likely have not, as you shouldn't have some a odd setup.

 

 

View solution in original post

Highlighted
Super User III
Super User III

Re: Copying SharePoint to On premise failing on name

Hi @RaoulDuke 

 

Glad that you found the solution. Thanks for sharing the knowledge. 

 



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

Power Automate Video Tutorials

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Upcoming Events

Experience what’s next for Power Automate

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Top Solution Authors
Top Kudoed Authors
Users online (6,189)