cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Copying entries from one sharepoint to another

Hi,

I have created a flow which copies 4 fields to one sharepoint from another.

ID, Date, Author & Comment. 

image.png

 

This works 80 % of the times. However, it seems that some of the "Comments" are empty after this flow runs. Comments are mandatory in Sharepoint 1 (Parent site) and there are no empty rows. I have checked that all the users have read/write access to sharepoint 2 (the receiving sharepoint site). Is there a better way of making sure all the comments are trensferred from Sharepoint 1 to Sharepoint 2?

 

Any help is much appreciated 🙂

 

Regards,

Trond

 
10 REPLIES 10
Dual Super User III
Dual Super User III

Hi!
Did you inspect flow execution results?
https://docs.microsoft.com/en-us/power-automate/see-a-flow-run
Please also note the trigger is executed when an item is created or modified. The modification of items in sharepoint list 1 forces the creation of a new item in sharepoint list 2 also. Is this design intent?


Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Anonymous
Not applicable

Hi @efialttes ,

 

I do not get any error Messages. A New item is to be created in Sharepointlist 2. This is intent.

Right now it creates a New item, but without the comment (just ID, Name and Date).

 

Hey @Anonymous 

The flow execution wouldn't throw an error if an item didn't contain data... you still need to check the execution results to see if the items where the 'comment' field which generate a null value actually have a value... can you verify as @efialttes suggested?

Noting; just because the field is mandatory doesn't mean all items will have a value for the 'comments' field... for example the field could have been made mandatory after items had already been added, or another mechanism is adding data without setting the field... but the first check is to see the actual items contain a value in the Flow execution results, and then verify in SharePoint.

Thinking about it... on your source list check the 'Items that need attention' view.... which will show any items missing values for mandatory columns

a.png

 

HTH

Jay

-------------------------------------------------------------------------

If I have answered your question, please mark your post as Solved.

If you like my response, please give it a Thumbs Up

 

Anonymous
Not applicable

Hi @Jay-Encodian ,

 

I've checked that the Comment Field has a value in the Source list (sharepoint1).

I checked "tems that need attention" and there is a list of  approx 20 items. But how can I get information of what is the real issue With these? frustrating that some comments are transferred to Sharepoint2 and some don't...

Hey @Anonymous 

Can you share screen shots of the execution history showing where there is a null value for the comments field, also showing a screenshot of the corresponding item in SharePoint? 

Thanks J

Anonymous
Not applicable

Hi @Jay-Encodian ,

 

image.png

 

As you can see the flow was successfully run and the source Sharepoint has comment:

image.png

 

However, the other sharepoint list is not picking up this comment: It's empty

image.png

From the Run history I can see that the Body in the "Create Item" for comment is "Null":

"CommentDate": "2019-12-12T10:53:41Z",

  "Comment": null

 

Any idea why?

Hi
On the pagw you take the screenshot, if you doubleclick on the trigger, you will be able to inspect its outputs, and identify which item from the list is related to. Can you share a new screenshot with this details?
Hope this helps


Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Anonymous
Not applicable

Hi @efialttes ,

Here are the details. I noticed that the input from Andreas (the editor) is missing the "Comment" Field. The 3 other Fields from the second (receiving) sharepoint is showing (ID, Name and date).

image.png

image.png

image.png

image.png

image.png

image.png

I find it strange that the "Comment" field is missing here... the 3 other fields are showing (ID, Name and Date).I find it strange that the "Comment" field is missing here... the 3 other fields are showing (ID, Name and Date).

image.png

image.png

image.png

image.png

regards,

Trond

So, the problem is not the flow itself, but the info from sharepint that triggers it... that's really weird.
1. How is Comments column defined in sharepont list? and
2. Did the Comments Column already exist on your SP list when you created the Flow? Or, was this column added later?


Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Anonymous
Not applicable

1. image.pngimage.png

2. The Comment Field was already there. This is not a Field that I added after the flow creation

 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Top Kudoed Authors
Users online (9,418)