cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
APearsonUSMC
New Member

Create CSV file in SP Library from SharePoint List; Getting Error: 'from' property value in 'table' action...

I created a flow to grab new or modified list data and create a CSV file in a SP library that I can then work with in PowerBI. 

The flow fails at the 'Create CSV table' step, giving me this error:

  • BadRequest. The 'from' property value in the 'table' action inputs is of type 'Object'. The value must be of type 'Array'.
  • The 'from' property value in the 'table' action inputs is of type 'Object'. The value must be of type 'Array'.

I am not a programmer/developer, and I am not sure how to proceed. 

 

THANK YOU for any time/effort you can provide. 

Anthony

1 ACCEPTED SOLUTION

Accepted Solutions

@APearsonUSMC 

Please take a look at my screen shot below.  Be sure that you select "Value - list of items" for the input to the Create CSV table action.

image.png

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

View solution in original post

7 REPLIES 7
ScottShearer
Super User III
Super User III

@APearsonUSMC 

Can you post a screen shot of your Flow?  That will be a big help to those who want to assist.

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

Here you go, thank you! Do you need any other detail(s)?

 

error_Annotation 2020-07-21 091604.pngerror_Annotation 2020-07-21 091712.png

@APearsonUSMC 

Please take a look at my screen shot below.  Be sure that you select "Value - list of items" for the input to the Create CSV table action.

image.png

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

View solution in original post

That worked beautifully. Thank you. I was using 'List of Values', and that wasn't working.

The flow progressed to the next step - and a new issue came up that I didn't know about. I didn't realize that I couldn't create a file using the same filename over and over. 

I can repost this in a new thread, since the original question I had was solved. Do you prefer that? 

Otherwise, here is the error:

APearsonUSMC_1-1595340818819.png

A file with the name Shared Documents/Research/SkyEvalDataCurrent.csv already exists. It was last modified by i:0#.f|membership|*********@*******.com on 21 Jul 2020 05:17:03 -0700.
clientRequestId: 010b7ec0-bcf4-4044-bcbb-8c4a0de83a55
serviceRequestId: 010b7ec0-bcf4-4044-bcbb-8c4a0de83a55

 

@APearsonUSMC 

Try using a delete file action before your create file action.  Let me know if you are still having issues.

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

You are fantastic, Scott. Thank you SO MUCH for your time, expertise, and willingness to teach others. VERY grateful.

@APearsonUSMC 

Thanks!

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Users online (70,635)