cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
JBSF
Level: Powered On

Create HTML table constantly fails

Hello,

 

I have a flow that fails on the Create HTML Table step consistently whenever any change is made to the flow.  The basic layout of my flow is as follows.

 

Trigger every hour -> Get items from Sharepoint list -> Filter array -> Create HTML table from filtered items -> Send email with HTML table in body.

 

The problem is that whenever any change is made to this flow - changing the name of the flow, adding an email address to the 'Send email step,' or rewording the body of  the email, for example - the flow will fail on the next run at the Create HTML table step.  The error will read:

 

'The execution of template action 'Create_Table' failed. The column values could not be evaluated: 'The template language expression 'item()['Column']' cannot be evaluated because property 'Column' doesn't exist, available properties are 'Other columns'. Please see https://aka.ms/logicexpressions for usage details.'

 

The Sharepoint list these items are in contains 300 items, and no changes have been made to the columns in it since it was created months ago, before these flows were created.  The only solution I have been able to find is to delete all Dynamic Content from the Create HTML table step and reenter it, then the flow will run fine until the next minor change.  This cannot be done when other small changes to the flow are made; the changes must be saved, the flow exited from then reentered, and then the HTML tables recreated.  

 

Is there a reason these flows keep failing, and is there a solution I can use?  It is very tedious and time consuming - I am currently spending more time editing and fixing this flow than I would spend on the emails before we used Sharepoint - but emailed tables are necessary to my work's function and use of Sharepoint.  I have several similar flows, some with half a dozen HTML tables, and all share the same problem.  Thank you for your help.

 

2 REPLIES 2
Community Support Team
Community Support Team

Re: Create HTML table constantly fails

Hi @JBSF,

 

You could try troubleshooting by following a few methods:

  1. Check if there are any columns exist in SharePoint list that are mentioned in the error message.
  2. Try to reconfigure the connection of the relevant action, or delete the connection of the relevant connector, and then reconfigure the connection.
  3. Export the Flow and re-import it as a new Flow.

Please take a try and see if issue still exists.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
JBSF
Level: Powered On

Re: Create HTML table constantly fails

Thank you for the suggestions.  All the columns in the list are mentioned in the error message, and no changes have been made to them.  I have one flow that contains an HTML table made from the contents of a Filter action that does not reaquire remaking with every change, and that flow also draws from the same list.  The connection has been reset and reconfigured recently and no change occured - the flow still failed with every change.  I have also saved this flow as multiple different copies to make other flows, and all have the same issue.  Is there anything else I can try?

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 185 members 5,304 guests
Recent signins:
Please welcome our newest community members: