cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Resolver I
Resolver I

Create Record - Blank Values Causing Problems

Hi all!  Within a 'Create Record' action, I'm getting errors whenever my dynamics content doesn't have a value:
The runtime value '""' to be converted doesn't have the expected format 'Integer/int32

I've tried to solve for this by using if statements (examples below), but I'm still getting the errors.  Any ideas?

if(equals(items('Apply_to_each')['Revenue'], null), null, items('Apply_to_each')['Revenue'])

i've also tried '' to see if the check for null value wasnt working:

if(equals(items('Apply_to_each')['Revenue'], ''), null, items('Apply_to_each')['Revenue'])

 

2 REPLIES 2
Super User II
Super User II

Hi @Connor551,

 

Try and use the empty function to check if it is empty. Here is an example, let me know if it works:

if(empty(items('Apply_to_each')?['Revenue']), null, items('Apply_to_each')?['Revenue'])

 

Memorable Member
Memorable Member

Looking at the function you use the word revenue.  Revenue indicates to me currency value which is not an integer.  Are you sure it is  a null value problem. 

 

Put a compose action in the process before the failure.   Run the flow and look at what value teh compose returns.  This might help to analyze your problem

Helpful resources

Announcements
Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (75,061)