cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Connor551
Resolver I
Resolver I

Create Record - Blank Values Causing Problems

Hi all!  Within a 'Create Record' action, I'm getting errors whenever my dynamics content doesn't have a value:
The runtime value '""' to be converted doesn't have the expected format 'Integer/int32

I've tried to solve for this by using if statements (examples below), but I'm still getting the errors.  Any ideas?

if(equals(items('Apply_to_each')['Revenue'], null), null, items('Apply_to_each')['Revenue'])

i've also tried '' to see if the check for null value wasnt working:

if(equals(items('Apply_to_each')['Revenue'], ''), null, items('Apply_to_each')['Revenue'])

 

2 REPLIES 2
Expiscornovus
Super User II
Super User II

Hi @Connor551,

 

Try and use the empty function to check if it is empty. Here is an example, let me know if it works:

if(empty(items('Apply_to_each')?['Revenue']), null, items('Apply_to_each')?['Revenue'])

 

leyburn19
Memorable Member
Memorable Member

Looking at the function you use the word revenue.  Revenue indicates to me currency value which is not an integer.  Are you sure it is  a null value problem. 

 

Put a compose action in the process before the failure.   Run the flow and look at what value teh compose returns.  This might help to analyze your problem

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (89,188)