cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Create pdf from Html text - flow captures wrong data

Hi,

 

I have custom form app based on sharepoint list in powerApps.

My flow converts html text from powerapps to pdf version of submited form. The trigger is standard save button.

My problem is that, when I submit new form, flow always captures wrong data, not what I entered, and saved into sharepoint list.

 

For example:

Most of fields are Parent.Default, and flows always capture data from my first item on sharepoint list (thats what I see in powerapps studio no matter how many items on list I have).

One of my fields are non-editable with formula on default Last(sharepointlist).columnName + 1 . And flow gets exactly this value - if my last list item was NO4 (which I want inside of my created pdf), flow captures value NO5.

 

I think maybe it is somehow connected with reseting form, or Item property of SharePointForm1, but I dont know how to fix this.

 

Here is my code for SharePointIntegration and SharePointForm1:

SharePointIntegration:
OnNew:  NewForm(SharePointForm1);
OnSave: SubmitForm(SharePointForm1);

SharePointForm1:
OnSuccess: createPDF_flow.Run(main.HtmlText, SharePointForm1.LastSubmit.ID);
           RequestHide();
Item: If(
        IsBlank(SharePointIntegration.Selected) || IsEmpty(SharePointIntegration.Selected),
        First(sharepointlist),
        SharePointIntegration.Selected
)

 

Do you know how to handle this error ?

 

Thank you

 

1 ACCEPTED SOLUTION

Accepted Solutions
v-bacao-msft
Community Support
Community Support

 

Hi @Anonymous ,

 

Could you share a screenshot of the Flow configuration? We can try to analyze whether the result is due to the configuration of Flow based on the screenshot.

You could also post your question in the PowerApps community to see if there is a problem with the formula you are currently using.

https://powerusers.microsoft.com/t5/Power-Apps-Community/ct-p/PowerApps1

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
v-bacao-msft
Community Support
Community Support

 

Hi @Anonymous ,

 

Could you share a screenshot of the Flow configuration? We can try to analyze whether the result is due to the configuration of Flow based on the screenshot.

You could also post your question in the PowerApps community to see if there is a problem with the formula you are currently using.

https://powerusers.microsoft.com/t5/Power-Apps-Community/ct-p/PowerApps1

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Thank you I will try to ask on PowerApps community, because when I check successful flows it captures bad data on very beginning ( on "PowerApps" trigger). Sorry for confusing communities

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

PWREduCon768x460.png

Join us at PWR EduCon - A Power Platform Conference

Learn from the top Power BI, Power Apps, Power Automate & Power Virtual Agents experts!

Power automate tips 768x460 v2.png

Restore a Deleted Flow

Did you know that you could restore a deleted flow? Check out this helpful article.

Users online (2,538)